This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282416 - Configuring provisioning network on bond fails via tripleO templates
Configuring provisioning network on bond fails via tripleO templates
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ---
: 10.0 (Newton)
Assigned To: Jiri Stransky
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 05:50 EST by Jaison Raju
Modified: 2016-10-14 11:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 11:33:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network yaml files (3.92 KB, application/zip)
2015-11-16 06:09 EST, Jaison Raju
no flags Details

  None (edit)
Description Jaison Raju 2015-11-16 05:50:54 EST
Description of problem:
Configuring provisioning network on bond fails via tripleO templates .

              members:
                -
                  type: ovs_bond
                  name: bond-prov
                  ovs_options: {get_param: BondInterfaceOvsOptions}
                  members:
                    -
                      type: interface
                      name: em1
                      primary: true
                    -
                      type: interface
                      name: em2

The node gets written with image but the network configuration seen after reboot
makes it inaccessible .

em1 seems to have dhcp IP address , but em2 seems to have discovery IP address .
The stack create seems to be stuck indefinitely .

Version-Release number of selected component (if applicable):
RHOS7
OSPD7
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
Due to discovery IP on em2 , cannot ssh from director to em1 / dhcp IP .

How reproducible:
Not confirmed .

Steps to Reproduce:
1. Configure controllers with 2 nics as bond .
2.
3.

Actual results:
em1 & em2 are not bonded & em2 has discovery IP & em1 has dhcp IP .

Expected results:
Bond is created using em1 & em2 & has an accessible IP over dhcp range .

Additional info:
to access node at this point, we copy ssh private key to compute & ssh from compute .
Disabling em2 also allow access to controller at this point .
Comment 2 Jaison Raju 2015-11-16 06:09 EST
Created attachment 1094849 [details]
network yaml files
Comment 6 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 8 Dan Sneddon 2016-10-14 11:33:42 EDT
Bonds on the provisioning network should work, certainly with OSP-Director 7.3+. We do test bonding via the provisioning network.

The behavior where some of the bond slaves may receive a discovery IP is transient, and that IP should disappear when the bond is configured.

Note You need to log in before you can comment on or make changes to this bug.