Bug 1282441 - [SR-IOV] - UI clusters less than 3.6 - 'passthrough' checkbox appears in vNIC profile dialog and 'pci-passthrough' type is part of the type list in the vNIC's dialog
[SR-IOV] - UI clusters less than 3.6 - 'passthrough' checkbox appears in vNI...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0.2
x86_64 Linux
medium Severity medium (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Dan Kenigsberg
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 07:28 EST by Michael Burman
Modified: 2016-02-18 06:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:04:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51395 master MERGED webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6 2016-01-11 10:58 EST
oVirt gerrit 51661 ovirt-engine-3.6 MERGED webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6 2016-01-12 05:20 EST
oVirt gerrit 51663 ovirt-engine-3.6.2 MERGED webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6 2016-01-12 05:21 EST

  None (edit)
Description Michael Burman 2015-11-16 07:28:18 EST
Description of problem:
[SR-IOV] - UI  clusters less than 3.6 - 'passthrough' checkbox appears in vNIC profile dialog and 'pci-passthrough' type is part of the type list in the vNIC's dialog.

- Compatibility version- UI clusters less than 3.6 - sriov checkboxes(passthrough) should be disabled in the vNIC profile dialog and shouldn't appear in the vNICs type list(pci-passthrouhg)? 

- In current version 3.6.0.3-0.1.el6 in clusters 3.5, 'passthrough' checkbox appears in vNIC profile dialog and 'pci-passthrough' type is part of the type list in the VM vNIC's dialog. This should be disabled or shouldn't be exist at all for clusters below 3.6.

Version-Release number of selected component (if applicable):
3.6.0.3-0.1.el6

How reproducible:
100
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-16 08:40:37 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 2 Michael Burman 2016-01-11 08:17:32 EST
After discussing with DEV, we have 2 issues here:

1) Clusters less then 3.6 - Agreed that 'passthrough' checkbox should be disabled. 
2) 'pci-passthrough' type is part of the type list in a vNIC dialog in clusters less then 3.6 - Agreed that the current validation is enough -->
There is a validation for the 'passthrough' profile and type for cluster version less then 3.6 and approving such operation is not supported. Appropriate tool tip is appear to explain the reason. 

- Separate bug will be reported for such validations in REST API.
Comment 3 Michael Burman 2016-01-13 11:37:23 EST
Verified on - 3.6.2.5-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.