Bug 1282453 - publican add_revision fails to increment revision number
publican add_revision fails to increment revision number
Status: CLOSED WORKSFORME
Product: Publican
Classification: Community
Component: publican (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 08:16 EST by Laura Novich
Modified: 2017-01-09 06:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-09 06:47:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laura Novich 2015-11-16 08:16:10 EST
Description of problem:
I manually updated a revision in the revision history and saved the file. 
Then I ran the "publican add_revision" command to a new member 
the member was added, but the revision history number was the same as the number for the revision I added manually.
Oddly enough Publican did not fail to brew with two entries with the same revision number.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
I expect publican build and brew to fail when there are 2 entries with the same revision number
Also I expect publican_add_revision to increment the revision numbers.

Additional info:
Comment 2 Jeff Fearn 2017-01-09 06:47:08 EST
Works for me, would need the broken files to test.

Note You need to log in before you can comment on or make changes to this bug.