Bug 1282454 - IPA can't detect the boot NIC
IPA can't detect the boot NIC
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: beta
: 8.0 (Liberty)
Assigned To: Ivan Chavero
yeylon@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 08:17 EST by Marius Cornea
Modified: 2016-04-18 02:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:12:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
node introspection screenshot (78.65 KB, image/png)
2015-11-16 08:17 EST, Marius Cornea
no flags Details
inspector.log (1.60 MB, application/x-gzip)
2015-11-16 08:17 EST, Marius Cornea
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1517941 None None None Never
OpenStack gerrit 247556 None None None Never

  None (edit)
Description Marius Cornea 2015-11-16 08:17:03 EST
Created attachment 1094870 [details]
node introspection screenshot

Description of problem:
After introspection the ironic nodes end up having 2 ports. It looks from the console output during introspection that there's created an ironic port for each interface that got an IP address via DHCP.

Version-Release number of selected component (if applicable):
openstack-ironic-api-4.2.0-2.1.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
python-ironic-inspector-client-1.2.0-4.el7ost.noarch
openstack-ironic-common-4.2.0-2.1.el7ost.noarch
openstack-ironic-inspector-2.2.2-1.el7ost.noarch
openstack-ironic-conductor-4.2.0-2.1.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Register ironic nodes that have 1 nic connected to the provisioning network and another nic connected to a network that provides DHCP services 
2. openstack baremetal introspection bulk start
3. ironic node-port-list 31ddb925-8ea7-4655-aee6-c6207aa1f362

Actual results:
+--------------------------------------+-------------------+
| UUID                                 | Address           |
+--------------------------------------+-------------------+
| ab41f108-1808-4217-9e65-65333f56b2a5 | a0:36:9f:22:e7:50 |
| bde12d5c-a639-4f42-8679-13794d81b99f | f0:4d:a2:73:2f:b1 |
+--------------------------------------+-------------------+

Expected results:
Only the port with the mac address connected to the provisioning exists.

Additional info:
Attaching a screenshot from the introspection process and the ironic-inspector.log.
Comment 2 Marius Cornea 2015-11-16 08:17 EST
Created attachment 1094871 [details]
inspector.log
Comment 3 Dmitry Tantsur 2015-11-16 08:23:02 EST
Yeah, I see boot_interface set to None in data received from IPA.
Comment 4 Ofer Blaut 2015-11-18 08:39:42 EST
Seems relate to https://bugs.launchpad.net/ironic/+bug/1405131
Comment 5 Dmitry Tantsur 2015-11-19 10:00:20 EST
Seems like BOOTIF variable is no longer passed after we've moved ironic-inspector installation to puppet.
Comment 6 Dmitry Tantsur 2015-11-19 10:15:55 EST
Can someone please test the proposed patch https://review.openstack.org/#/c/247556/ by applying it to /usr/share/openstack-puppet/modules/ironic/ before installing the undercloud?
Comment 7 Jon Schlueter 2015-11-19 12:45:44 EST
sasha has confirmed this patch works.
Comment 9 Alexander Chuzhoy 2015-11-20 11:08:27 EST
Environment:
openstack-puppet-modules-7.0.1-2.el7ost.noarch


The nodes in my setup have only one port now and this BZ can be verified from my POV.
Comment 10 Alexander Chuzhoy 2015-11-20 11:58:30 EST
Verifying based on comment #9.
Comment 11 errata-xmlrpc 2016-04-07 17:12:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.