Bug 1282460 - MUMPS build failed because libmpi_f77 is missing with last openmpi-1.10.0-10 used in rhel72-2015-10-15 snapshot
Summary: MUMPS build failed because libmpi_f77 is missing with last openmpi-1.10.0-10 ...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: MUMPS
Version: epel7
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio Trande
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1282958
Blocks: epel7ppc64le
TreeView+ depends on / blocked
 
Reported: 2015-11-16 13:30 UTC by Menanteau Guy
Modified: 2016-01-08 18:53 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-01-08 18:53:57 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2015-11-16 13:30:45 UTC
I tried to build MUMPS-5.0.1-4 epel7 ppc64le on a local environment using a RHEL7.2 snapshot of the 15th of october 2015, and it failed because with following error:
  /usr/lib64/openmpi/bin/mpif77 -shared ana_omp_m.o tools_common_mod.o mumps_static_mapping.o mumps_sol_es.o fac_future_niv2_mod.o mumps_comm_ibcast.o mumps_ooc_common.o double_linked_list.o fac_asm_build_sort_index_m.o fac_asm_build_sort_index_ELT_m.o omp_tps_common_m.o mumps_l0_omp_m.o front_data_mgt_m.o fac_maprow_data_m.o fac_descband_data_m.o fac_ibct_data_m.o ana_orderings.o ana_AMDMF.o bcast_errors.o estim_flops.o mumps_type_size.o mumps_type2_blocking.o mumps_version.o tools_common.o mumps_print_defined.o mumps_common.o mumps_orderings.o mumps_size.o mumps_io.o mumps_io_basic.o mumps_io_thread.o mumps_io_err.o ana_set_ordering.o mumps_numa.o -Wl,-soname,libmumps_common-5.0.0.so -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,now -Wl,--as-needed -L../lib -L/usr/lib64 -lmetis -L../PORD/lib/ -lpord -L/usr/lib64/openmpi/lib -lesmumps -lscotch -lscotcherr -lptesmumps -lptscotch -lptscotcherr -lpthread -L/usr/lib64/openmpi -L/usr/lib64/openmpi/lib -lmpi  -lscalapack -lmpiblacs -lopen-rte -lopen-pal -lmpi_f77 -lmpi -lmetis -o ../lib/libmumps_common-5.0.0.so -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,now -Wl,--as-needed -Wl,-z,defs
/usr/bin/ld: cannot find -lmpi_f77
collect2: error: ld returned 1 exit status

It seems that openpmi-1.10.0-10 found in my last rhel7.2 snapshot dating of the 15th of october 2015 ,does not provide any more libmpi_f77

Comment 1 Antonio Trande 2015-11-16 13:33:08 UTC
Let me check.

Comment 2 Fedora Update System 2015-11-17 13:37:33 UTC
MUMPS-5.0.1-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-962c74f380

Comment 3 Menanteau Guy 2015-11-18 10:08:53 UTC
I tried to build MUMPS-5.0.1-5.el7.src.rpm in my same epel7 ppc64le RHEL7.2 local environment and got a new error:

make[1]: Entering directory `/builddir/build/BUILD/MUMPS_5.0.1/examples'
/usr/lib64/openmpi/bin/mpif77 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1  -m64 -mcpu=power7 -mtune=power8 -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,now -Dscotch -Dmetis -Dptscotch -Dintel_ -DALLOW_NON_INIT -I/usr/include/openmpi-ppc64le -I. -I../include -c csimpletest.F -o csimpletest.o
gfortran -o csimpletest -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,now csimpletest.o  ../lib/libcmumps.so ../lib/libmumps_common.so -L/usr/lib64 -lmetis -L../PORD/lib/ -lpord -L/usr/lib64/openmpi/lib -lesmumps -lscotch -lscotcherr -lptesmumps -lptscotch -lptscotcherr  -L/usr/lib64/openmpi   -lscalapack -lmpiblacs  -lblas -lpthread
/usr/bin/ld: csimpletest.o: undefined reference to symbol 'mpi_init_'
/usr/bin/ld: note: 'mpi_init_' is defined in DSO /usr/lib64/openmpi/lib/libmpi_mpifh.so.12 so try adding it to the linker command line
/usr/lib64/openmpi/lib/libmpi_mpifh.so.12: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[1]: Leaving directory `/builddir/build/BUILD/MUMPS_5.0.1/examples'

Note I am still using openmpi-1.10.0-10.el7.ppc64le

Comment 4 Fedora Update System 2015-11-19 23:49:57 UTC
MUMPS-5.0.1-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update MUMPS'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-962c74f380

Comment 5 Antonio Trande 2015-11-20 17:26:16 UTC
(In reply to Menanteau Guy from comment #3)
> I tried to build MUMPS-5.0.1-5.el7.src.rpm in my same epel7 ppc64le RHEL7.2
> local environment and got a new error:
> 
> make[1]: Entering directory `/builddir/build/BUILD/MUMPS_5.0.1/examples'
> /usr/lib64/openmpi/bin/mpif77 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
> -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4
> -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1  -m64
> -mcpu=power7 -mtune=power8 -Wl,-z,relro
> -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,now -Dscotch -Dmetis
> -Dptscotch -Dintel_ -DALLOW_NON_INIT -I/usr/include/openmpi-ppc64le -I.
> -I../include -c csimpletest.F -o csimpletest.o
> gfortran -o csimpletest -Wl,-z,relro
> -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,now csimpletest.o 
> ../lib/libcmumps.so ../lib/libmumps_common.so -L/usr/lib64 -lmetis
> -L../PORD/lib/ -lpord -L/usr/lib64/openmpi/lib -lesmumps -lscotch
> -lscotcherr -lptesmumps -lptscotch -lptscotcherr  -L/usr/lib64/openmpi  
> -lscalapack -lmpiblacs  -lblas -lpthread
> /usr/bin/ld: csimpletest.o: undefined reference to symbol 'mpi_init_'
> /usr/bin/ld: note: 'mpi_init_' is defined in DSO
> /usr/lib64/openmpi/lib/libmpi_mpifh.so.12 so try adding it to the linker
> command line
> /usr/lib64/openmpi/lib/libmpi_mpifh.so.12: could not read symbols: Invalid
> operation
> collect2: error: ld returned 1 exit status
> make[1]: Leaving directory `/builddir/build/BUILD/MUMPS_5.0.1/examples'
> 
> Note I am still using openmpi-1.10.0-10.el7.ppc64le

Please, try this release: http://koji.fedoraproject.org/koji/buildinfo?buildID=700514

Comment 6 Fedora Update System 2015-11-24 13:31:18 UTC
MUMPS-5.0.1-8.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d20c4ae3b9

Comment 7 Fedora Update System 2015-11-26 00:54:07 UTC
MUMPS-5.0.1-8.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update MUMPS'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d20c4ae3b9

Comment 8 Fedora Update System 2015-12-12 19:23:24 UTC
MUMPS-5.0.1-8.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.