This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282499 - Evince only saves the first page of annotatations
Evince only saves the first page of annotatations
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 10:36 EST by Jonathan Smoker
Modified: 2015-11-24 20:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 20:17:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Smoker 2015-11-16 10:36:44 EST
Description of problem: I have a pdf document that I wanted to add annotations to. All seemed to be fine (annotations are visible as yellow boxes) and I can save a copy of the pdf but when I display the pdf only the annotations on the first page are visible. Luckly I have not closed the document so can cut and paste my work into ascii. 

If I do "properties" then it says PDF-1.5 produced by Tex

Version-Release number of selected component (if applicable):

Linux localhost.localdomain 4.1.10-200.fc22.x86_64 #1 SMP Mon Oct 5 14:22:49 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Sorry I dont know what version of evince I am using. 

How reproducible:

Steps to Reproduce:
1. Open evince i.e. evince mydocument.pdf
2. Create annotations on several pages. Works fine. If I do "list annotations" they are all visible in the open version of evince. 
3. Save a copy mydocument_saved
4. Display saved copy using evince or document viewer.

Actual results:

Only annotations on the first page are visible

Expected results:

Annotations on all pages should be visible

Additional info:

Thanks!

Jonathan
Comment 1 Felipe Borges 2015-11-23 09:57:55 EST
could you please provide a pdf example? I have tried to reproduce this bug here without success. It works as expected.
Comment 2 Jonathan Smoker 2015-11-24 20:17:06 EST
Sorry, I have tried to produce this myself again and there is no problem, the notes are saved OK. I have no idea what I did wrong last week, but evince is fine now with the annotations saved on all the pages as they should do. 

Apologies for the inconvenience!

Note that when I "save a copy" the create date always seems to be the same as the date the original was created and not the current date, but I guess this is by design.

Anyway, this can be closed of course. 

Thanks,

Jonathan 

-rw-rw-r--. 1 jsmoker jsmoker  29846 Nov  3 09:40 ediblesI.tex
-rw-rw-r--. 1 jsmoker jsmoker  84055 Nov 16 09:29 ediblesI_edited.odg
-rw-rw-r--. 1 jsmoker jsmoker 611417 Nov 16 09:29 ediblesI_edited.pdf
-rw-rw-r--. 1 jsmoker jsmoker 145960 Nov 16 09:49 Jonathan.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 final.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 finala.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 finalaaaa.pdf
-rw-rw-r--. 1 jsmoker jsmoker 146808 Nov 16 09:49 EDIBLES_NICEST.pdf
-rw-rw-r--. 1 jsmoker jsmoker 145390 Nov 16 09:49 EDIBLES_NICE.pdf
-rw-rw-r--. 1 jsmoker jsmoker 146549 Nov 16 09:49 ediblesI_test_two.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 ediblesI_test_three.pdf
-rw-rw-r--. 1 jsmoker jsmoker 145982 Nov 16 09:49 ediblesI_test.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 ediblesI.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 ediblesI_edited_smoker.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 ediblesI_edited_smoker_page2.pdf
-rw-rw-r--. 1 jsmoker jsmoker 144538 Nov 16 09:49 ediblesI_edited_smoker_corrections.pdf
-rw-rw-r--. 1 jsmoker jsmoker 146551 Nov 16 09:49 ediblesEditedNov20.pdf
-rw-rw-r--. 1 jsmoker jsmoker 666143 Nov 16 12:41 Page2.jpg
-rw-rw-r--. 1 jsmoker jsmoker 771513 Nov 16 12:46 Page3.jpg
-rw-rw-r--. 1 jsmoker jsmoker 342988 Nov 16 12:48 Page4.jpg
-rw-rw-r--. 1 jsmoker jsmoker 139704 Nov 16 12:49 Page5.jpg
-rw-rw-r--. 1 jsmoker jsmoker 522112 Nov 16 12:56 Page1.jpg

Note You need to log in before you can comment on or make changes to this bug.