Bug 1282511 - GTK+ 3.20 port
GTK+ 3.20 port
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: greybird (Show other bugs)
24
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jayson Rowe
Fedora Extras Quality Assurance
https://git.gnome.org/browse/gtk+/tre...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 11:11 EST by poma
Modified: 2016-08-31 23:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: greybird-3.20.0-2.fc25 greybird-3.20.0-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 12:30:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
greybird-gtk3-theme - GTK+ comparison (407.37 KB, image/png)
2015-11-16 11:11 EST, poma
no flags Details
Upstream - GTK+ 3.20 port based on Blackbird theme, work of Eric Koegel (460.42 KB, patch)
2016-06-04 05:37 EDT, poma
no flags Details | Diff
Downstream - GTK+ 3.20 port based on Blackbird theme, work of Eric Koegel (495.82 KB, patch)
2016-06-04 05:40 EDT, poma
no flags Details | Diff
Upstream: Greybird GTK-3.20 port - based on Blackbird theme (462.29 KB, patch)
2016-06-06 18:51 EDT, poma
no flags Details | Diff
Fedora: Greybird GTK-3.20 port - based on Blackbird theme (512.19 KB, patch)
2016-06-06 18:53 EDT, poma
no flags Details | Diff
Upstream: Greybird GTK-3.20 port - based on Adwaita theme (275.75 KB, patch)
2016-06-10 17:20 EDT, poma
no flags Details | Diff
Upstream: Greybird GTK-3.20 port - based on Adwaita theme (275.87 KB, patch)
2016-06-12 10:25 EDT, poma
no flags Details | Diff

  None (edit)
Description poma 2015-11-16 11:11:05 EST
Created attachment 1095002 [details]
greybird-gtk3-theme - GTK+ comparison

Description of problem:
GTK+ 3.19 makes not so beautiful albatross-gtk3-theme, bluebird-gtk3-theme and greybird-gtk3-theme

Version-Release number of selected component (if applicable):
gtk3-3.19.1-1.fc24

How reproducible:
101%

Steps to Reproduce:
1. Run Fedora-Live-Xfce-i686-rawhide-20151116.iso

Actual results:
Themes not so beautiful

Expected results:
Themes so beautiful

Additional info:
"The Shimmer Project was founded in 2009 to make Open Source beautiful."
http://shimmerproject.org
Comment 1 Matthias Clasen 2015-12-04 15:12:39 EST
Themes will need adjustments for 3.20, there is no way around it.

See https://blogs.gnome.org/mclasen/2015/11/20/a-gtk-update/ for more information
Comment 2 poma 2016-01-21 06:46:50 EST
Is anyone working on a solution?
Comment 3 Matthias Clasen 2016-01-21 14:53:38 EST
Not me. You should probably contact the authors of the themes you care about.
Comment 4 Matthias Clasen 2016-01-24 11:35:02 EST
Moving this to one of the themes mentioned in the description
Comment 5 poma 2016-01-25 17:27:16 EST
- XUBUNTU:

http://cdimage.ubuntu.com/xubuntu/daily-live/current/xenial-desktop-amd64.manifest
...
greybird-gtk-theme	2.0.2-0ubuntu1
libgtk-3-bin	3.18.6-1ubuntu1


http://changelogs.ubuntu.com/changelogs/pool/universe/s/shimmer-themes/shimmer-themes_2.1.0-0ubuntu1/changelog

shimmer-themes (2.1.0-0ubuntu1) xenial; urgency=medium

  * New theme snapshots (Greybird:fafd278, Numix:70b2565) (LP: #1535163)
    - Improved support for GTK 3.18
  * debian/control, Makefile:
    - Compile Numix sass assets
  * Drop unmaintained Albatross, Bluebirdm and Orion GTK themes
...


- FEDORA:

Fedora-Live-Xfce-x86_64-rawhide-20160125
http://koji.fedoraproject.org/koji/getfile?taskID=12675997&name=livecd.log&offset=-157000
...
greybird-gtk3-theme-1.6.2-1.fc24.noarch
gtk3-3.19.7-1.fc24.x86_64



- THEME:
https://github.com/shimmerproject/Greybird/blob/master/README#L9
"Greybird is the default theme in Xubuntu 11.04 onwards."



Until Xubuntu reaches GTK+ 3.19.x ...
Comment 6 poma 2016-01-29 11:07:15 EST
If any of you intend to solve this problem, make a note here so we can share the task.
Comment 7 Mukundan Ragavan 2016-01-31 20:47:45 EST
I am not sure I understand ... the latest upstream release for greybird seems to be 1.6.2 (github).

Ubuntu seems to be packaging snapshots ..
Comment 8 poma 2016-02-08 07:46:58 EST
https://help.github.com/articles/creating-an-issue
i.e.
https://github.com/shimmerproject/Greybird/issues/new

You wanna take the initiative,
to create a new GTK+ 3.20 branch for the Greybird theme?

This is already done for the "mate-themes"
https://github.com/mate-desktop/mate-themes/tree/gtk3.20
Comment 9 poma 2016-02-16 11:54:43 EST
(In reply to Mukundan Ragavan from comment #7)
> I am not sure I understand ... the latest upstream release for greybird
> seems to be 1.6.2 (github).
> 
> Ubuntu seems to be packaging snapshots ..

Mukundan, you always play this "lost in space" role? :)

What you can find at
https://github.com/shimmerproject/Greybird
is GTK+ 3.18 related, e.g. Fedora 22 and 23, but not more Fedora 24 and so on.

In a nutshell:
"Gtk3.20 will force rewrite of all MATE themes-and more"
http://forums.mate-desktop.org/viewtopic.php?f=2&t=3610#p11151

For what I comprehend, X/Ubuntu is far far away from GTK+ 3.20 embracing, and guess what, major upstream developer drives just that.
What do you think, how much is he motivated to do a job for us, here. :)

So here's the question once more, do you intend to join efforts, or not?
Comment 10 Jan Kurik 2016-02-24 10:29:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 11 poma 2016-02-26 07:34:58 EST
The question is raised for all of you,
do you intend to join efforts, or not?
Comment 12 poma 2016-02-27 05:57:53 EST
Bye
Comment 13 poma 2016-06-04 05:37 EDT
Created attachment 1164766 [details]
Upstream - GTK+ 3.20 port based on Blackbird theme, work of Eric Koegel

As the skeleton it is good enough to continue working on it - needs some love for colores adjustments, applications, etc.
If someone wants to push it upstream, go ahead.

https://github.com/shimmerproject/Greybird
Comment 14 poma 2016-06-04 05:40 EDT
Created attachment 1164767 [details]
Downstream - GTK+ 3.20 port based on Blackbird theme, work of Eric Koegel
Comment 15 poma 2016-06-06 18:51 EDT
Created attachment 1165425 [details]
Upstream: Greybird GTK-3.20 port - based on Blackbird theme

GTK+ 3.20 port - based on Blackbird theme, work of Eric Koegel
incl. LightDM Greeter GTK+ 3.20 port and gtk-widgets.css GTK+ 3.20 tune up,
base states, entry, switch and textview
Comment 16 poma 2016-06-06 18:53 EDT
Created attachment 1165439 [details]
Fedora: Greybird GTK-3.20 port - based on Blackbird theme

GTK+ 3.20 port - based on Blackbird theme
Comment 17 poma 2016-06-06 18:55:35 EDT
Test builds:
http://goo.gl/Gm4ffO
themes
Comment 18 poma 2016-06-10 17:20 EDT
Created attachment 1166736 [details]
Upstream: Greybird GTK-3.20 port - based on Adwaita theme


Greybird GTK+ 3.20 port - based on Adwaita theme,
incl. lightdm-gtk-greeter.css GTK+ 3.20 port
For testing purposes only!
Comment 19 Kevin Fenzi 2016-06-11 18:35:10 EDT
You should work with upstream on this work and land it there and we can pick it up in the next release.
Comment 20 poma 2016-06-12 10:25 EDT
Created attachment 1167162 [details]
Upstream: Greybird GTK-3.20 port - based on Adwaita theme

Greybird GTK+ 3.20 port - based on Adwaita theme,
incl. lightdm-gtk-greeter.css GTK+ 3.20 port
For testing purposes only!
Comment 21 poma 2016-08-17 06:59:00 EDT
Greybird 3.20.0

    support for Gtk3.20
    ported to SASS

The port is based on Adwaita 3.20.6

https://github.com/shimmerproject/Greybird/releases
Comment 22 Fedora Update System 2016-08-18 21:57:44 EDT
greybird-3.20.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1d7dc6b015
Comment 23 Fedora Update System 2016-08-18 21:59:04 EDT
greybird-3.20.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d8490eb50
Comment 24 Fedora Update System 2016-08-19 12:50:53 EDT
greybird-3.20.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d8490eb50
Comment 25 Fedora Update System 2016-08-19 19:21:43 EDT
greybird-3.20.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1d7dc6b015
Comment 26 Fedora Update System 2016-08-31 12:30:22 EDT
greybird-3.20.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2016-08-31 23:20:26 EDT
greybird-3.20.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.