Bug 128252 - knfsd needs to support FSID as submitted in 2.4.20pre2
knfsd needs to support FSID as submitted in 2.4.20pre2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 16:47 EDT by Josh Freedman
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 06:58:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Freedman 2004-07-20 16:47:36 EDT
Description of problem:
The newest AS2.1 Kernel (2.4.9-e37) does not support the FSID option 
in the export file (to allow exporting of filesystems of type nodev). 
This functionality was added to the kernel in 2.4.20-pre2 and IS 
present in the kernel provided in ES3.0. 

The patch requested was provided by Neil Brown in 2.4.20-pre2.

More details: Early version of knfsd only support exporting 
filesystems that have the FS_REQUIRES_DEV flag set. This rules out
many filesystems such as coda. A discussion in 2001 between Neil and 
Linus involved this and both agreed that it was possible to export 
nodev filesystems with the use of an FSID value, which this 
implements.

Version-Release number of selected component (if applicable):
kernel-2.4.9-e37

How reproducible:
Always

Steps to Reproduce:
1. try to export a filesystem mounted with Coda 

Actual Results:  exportfs errors. debug output from the kernel shows 
that it fails the following check:

fs/nfsd/export.c:215  if (!(inode->i_sb->s_type->fs_flags & 
FS_REQUIRES_DEV) 

Expected Results:  It should have properly exported the filesystem.

Additional info:

This doesn't qualify as a bug per se because it works as it was 
intended to in 2.4.9. However, because there is no workaround and the 
problem has been fixed in newer versions, I'm classifing this as a 
bug.
Comment 1 Jason Baron 2004-08-18 13:36:42 EDT
So is the change to basically just remove that check? 
Comment 3 Jeff Layton 2007-07-20 06:58:27 EDT
AS2.1 is now in maintenance mode, so it's very doubtful this will make it in.
Please move to a newer RHEL release if you need this functionality.

Note You need to log in before you can comment on or make changes to this bug.