Bug 1282522 - traceback on wrong pass to rhui-manager
traceback on wrong pass to rhui-manager
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Patrick Creech
Irina Gulina
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 11:41 EST by Irina Gulina
Modified: 2017-03-01 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-01 17:11:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Irina Gulina 2015-11-16 11:41:25 EST
Description of problem:
on RHEL7 iso and rhui-installer-0.0.24-1.el7ui.noarch 

On first login into rhui-manager

>> rhui-manager
Previous authentication credentials could not be found. Logging into
the RHUI.

If this is the first time using the RHUI, it is recommended to change
the user's password in the User Management section of RHUI Tools.

RHUI Username: admin
RHUI Password: 

RequestException: POST request on /pulp/api/v2/actions/login/ failed with 401 - Authentication with username admin failed: invalid username or password
Traceback (most recent call last):
  File "/bin/rhui-manager", line 16, in <module>
    rhui.tools.launcher.main()
  File "/usr/lib/python2.7/site-packages/rhui/tools/launcher.py", line 313, in main
    shell = RhuiShell(config, prompt, pulp_api, cdn_api, certificate_manager)
UnboundLocalError: local variable 'pulp_api' referenced before assignment


Changed the pass of admin and tried to login with wrong one

>> rhui-manager --username admin --password 654321
RequestException: POST request on /pulp/api/v2/actions/login/ failed with 401 - Authentication with username admin failed: invalid username or password
Traceback (most recent call last):
  File "/bin/rhui-manager", line 16, in <module>
    rhui.tools.launcher.main()
  File "/usr/lib/python2.7/site-packages/rhui/tools/launcher.py", line 313, in main
    shell = RhuiShell(config, prompt, pulp_api, cdn_api, certificate_manager)
UnboundLocalError: local variable 'pulp_api' referenced before assignment


How reproducible:
always

Steps to Reproduce:
1. use wrong pass when login into rhui-manager

Actual results:
Error msg + traceback


Expected results:
only Error msg
Comment 5 Irina Gulina 2016-08-02 09:10:10 EDT
Any time login with a wrong pass shows a traceback.
Comment 6 Irina Gulina 2016-08-16 09:56:18 EDT
Fixed on RHEL6 iso 20160809 and RHEL7 iso 20160811

RHUI Username: admin
RHUI Password: 

Invalid login, please check the authentication credentials and try again.
[root@rhua ~]# rhui-manager
Comment 7 errata-xmlrpc 2017-03-01 17:11:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0367

Note You need to log in before you can comment on or make changes to this bug.