Bug 1282566 - realtime profile: set unboud workqueues cpumask
realtime profile: set unboud workqueues cpumask
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.2
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: ZStream
Depends On: 1259043
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 13:31 EST by Jan Kurik
Modified: 2015-12-08 05:40 EST (History)
12 users (show)

See Also:
Fixed In Version: tuned-2.5.1-4.el7_2.1
Doc Type: Enhancement
Doc Text:
With this update, the cpumask of unbound workqueueus is set to the list of non-isolated cores in the "tuned" realtime profiles, as Red Hat Enterprise Linux and Real Time kernels now support setting the cpumask of unbound workqueues in sysfs.
Story Points: ---
Clone Of: 1259043
Environment:
Last Closed: 2015-12-08 05:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-16 13:31:13 EST
This bug has been copied from bug #1259043 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Tereza Cerna 2015-11-17 14:33:42 EST
===============================
Verified in:
   tuned-2.5.1-4.el7_2.1.noarch
PASS
===============================

There is new row with workqueue/cpumask in configuration file of realtime profile:

$ cat /usr/lib/tuned/realtime/tuned.conf
...
[sysfs]
/sys/bus/workqueue/devices/writeback/cpumask = ${not_isolated_cpumask}
/sys/devices/virtual/workqueue/cpumask = ${not_isolated_cpumask}
/sys/devices/system/machinecheck/machinecheck*/ignore_ce = 1
...

Content of /sys/devices/virtual/workqueue/cpumask is set to new value after activating realtime:

$ tuned-adm profile balanced
$ cat /sys/devices/virtual/workqueue/cpumask
ffff,ffffffff,ffffffff
$ tuned-adm profile realtime
$ cat /sys/devices/virtual/workqueue/cpumask
0000,00000000,ffffff0b
$

===============================
Reproduced in:
   tuned-2.5.1-4.el7.noarch
FAIL
===============================

$ cat /usr/lib/tuned/realtime/tuned.conf
...
[sysfs]
/sys/bus/workqueue/devices/writeback/cpumask = ${not_isolated_cpumask}
/sys/devices/system/machinecheck/machinecheck*/ignore_ce = 1
...

$ tuned-adm profile balanced
$ cat /sys/devices/virtual/workqueue/cpumask
ffff,ffffffff,ffffffff
$ tuned-adm profile realtime
$ cat /sys/devices/virtual/workqueue/cpumask
ffff,ffffffff,ffffffff
$
Comment 7 errata-xmlrpc 2015-12-08 05:40:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2570.html

Note You need to log in before you can comment on or make changes to this bug.