Bug 1282572 - Bugzilla links point to private pages.
Bugzilla links point to private pages.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-V2V_Guide (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Jiri Herrmann
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 13:53 EST by Bill Muller
Modified: 2016-05-19 08:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-19 08:47:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Muller 2015-11-16 13:53:19 EST
Description of problem:

Several links to Bugzilla entries in Appendix B point to restricted pages.



Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 6 V2V Guide dated July 2015.



How reproducible:

Click on bugzilla links in appendix B.



Steps to Reproduce:

1. Open the document, https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/V2V_Guide/index.html

2. Jump to Appendix B. Revision History

3. Select bugzilla link, for example BZ#1066257, https://bugzilla.redhat.com/show_bug.cgi?id=1066257



Actual results:

A bugzilla access denied page is displayed stating:

You are not authorized to access bug #1066257.

Most likely the bug has been restricted for internal development processes and we cannot grant access.

If you are a Red Hat customer with an active subscription, please visit the Red Hat Customer Portal for assistance with your issue

If you are a Fedora Project user and require assistance, please consider using one of the mailing lists we host for the Fedora Project.



Expected results:

The bugzilla entry should be displayed.



Additional info:



Document URL:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/V2V_Guide/index.html



Section Number and Name:

Appendix B. Revision History



Describe the issue: 

Links point to inaccessible pages.



Suggestions for improvement: 

If general users are not allowed access to the bugzilla entries referenced in this document, or any Red Hat document for that matter, they should be identified as private and no link provided.  In this one document alone I found twelve bugzilla links in appendix B which lead to an access denied message.



Additional information:
Comment 2 Jiri Herrmann 2016-02-19 05:57:08 EST
Hi Bill, a belated thank you for bring up this problem. 

We have actually been aware for some time that the Revision Histories in their current form are not helpful to the readers and also take up excessive space in the guides. Starting with the 6.8 release, therefore, the History is going to be condensed significantly, and will not contain any links.
 
Also note that due to the deprecation of the v2v utility on Red Hat Enterprise Linux 6, the v2v guide content is only going to receive the most urgent updates (along with the disclaimer about the deprecation).

Does this kind of solution sound satisfactory, or did you have something else in mind? 

Thanks,
Jirka
Comment 3 Bill Muller 2016-02-19 13:15:16 EST
Jiri,

That solution is perfectly acceptable.


Bill
Comment 4 Jiri Herrmann 2016-02-21 04:48:22 EST
Thanks for the response Bill!

Moving this BZ to VERIFIED, and will close with the release of RHEL 6.8
Comment 5 Jiri Herrmann 2016-05-19 08:47:44 EDT
Published with 6.8 GA:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/V2V_Guide/appe-V2V_Guide-Revision_History.html

Closing this BZ, feel free to reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.