Bug 1282583 - rhui-manager allows to set empty pass but fails to login using it
rhui-manager allows to set empty pass but fails to login using it
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Patrick Creech
Irina Gulina
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 14:31 EST by Irina Gulina
Modified: 2017-03-01 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-01 17:11:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Irina Gulina 2015-11-16 14:31:26 EST
Description of problem:
rhui-manager allows to set empty pass but fails to login using it

Version-Release number of selected component (if applicable):
RHEL7 iso
rhui-installer-0.0.24-1.el7ui.noarch

How reproducible:
always


Steps to Reproduce:
1. login into rhui-manager
2. press 'u' to manage RHUI users
3. press 'p' to change the pass
4. hit Enter twice when asked for a password
5. observe "Password successfully updated."
6. enter 'logout' (using 'exit' instead allows to login after)
7. try to login with empty pass
8. get Error and traceback


Actual results:
RequestException: POST request on /pulp/api/v2/actions/login/ failed with 401 - Authentication with username None failed: invalid SSL certificate.
Traceback (most recent call last):
  File "/bin/rhui-manager", line 16, in <module>
    rhui.tools.launcher.main()
  File "/usr/lib/python2.7/site-packages/rhui/tools/launcher.py", line 313, in main
    shell = RhuiShell(config, prompt, pulp_api, cdn_api, certificate_manager)
UnboundLocalError: local variable 'pulp_api' referenced before assignment

Expected results:
no empty pass allowed maybe?
Comment 4 Irina Gulina 2016-08-16 09:59:43 EDT
Fixed on RHEL6 iso 20160809 and RHEL7 iso 20160811

-= User Manager =-

   p   change a user's password

                                                   Connected: rhua.xyz.com
------------------------------------------------------------------------------
rhui (users) => p

Username: admin

New Password: [ENTER]
Re-enter Password: [ENTER]
Password can not be whitespace
Comment 5 errata-xmlrpc 2017-03-01 17:11:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0367

Note You need to log in before you can comment on or make changes to this bug.