Bug 1282593 - rhel-osp-director: 8.0 - /etc/neutron/plugin.ini has "tenant_network_types = gre" when the --neutron-network-type and --neutron-tunnel-types aren't specified.
rhel-osp-director: 8.0 - /etc/neutron/plugin.ini has "tenant_network_types =...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: RHOS Maint
Alexander Chuzhoy
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 15:28 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:42 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-tripleoclient-0.1.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:42:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 246595 None None None Never
Red Hat Product Errata RHEA-2016:0604 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 director Enhancement Advisory 2016-04-07 21:03:56 EDT

  None (edit)
Description Alexander Chuzhoy 2015-11-16 15:28:08 EST
rhel-osp-director: 8.0 - /etc/neutron/plugin.ini has  "tenant_network_types = gre" when the --neutron-network-type and --neutron-tunnel-types aren't specified.

Environment:
instack-undercloud-2.1.3-1.el7ost.noarch
python-neutron-7.0.0-3.el7ost.noarch
openstack-neutron-7.0.0-3.el7ost.noarch
openstack-neutron-ml2-7.0.0-3.el7ost.noarch
openstack-neutron-common-7.0.0-3.el7ost.noarch
openstack-neutron-lbaas-7.0.0-2.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch
python-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-metering-agent-7.0.0-3.el7ost.noarch
openstack-neutron-openvswitch-7.0.0-3.el7ost.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch


Steps to reproduce:
Deploy overcloud without setting the --neutron-network-type and --neutron-tunnel-types arguments.

Result:

tenant_network_types = gre in /etc/neutron/plugin.ini


Expected result:
tenant_network_types = vxlan
Comment 2 Mike Orazi 2016-02-03 12:33:49 EST
I'm assuming if you provide correct values, vxlan is set up properly and this is a request to change the default only.  If that is the case, I would suggest we drop blocker.  I am going to drop blocker now but if I misread the email and you are unable to achieve vxlan setups entirely, please propose blocker again.
Comment 3 Alexander Chuzhoy 2016-02-03 15:37:37 EST
Mike, this is just to change the default from GRE to VXLAN.
Comment 4 Mike Burns 2016-02-24 15:27:06 EST
The CLI doesn't set this default anymore and the templates default to vxlan, so this should be resolved.
Comment 7 Alexander Chuzhoy 2016-02-24 18:10:03 EST
Verified:

Environment:
python-tripleoclient-0.1.1-2.el7ost.noarch

Deployed without specifying --neutron-network-type
Checked the /etc/neutron/plugin.ini file on a controller:
tenant_network_types = vxlan
Comment 9 errata-xmlrpc 2016-04-07 17:42:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.