Bug 12826 - printtool did not detect DeskJet 690C
printtool did not detect DeskJet 690C
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-22 17:32 EDT by ccraig1
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:00:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ccraig1 2000-06-22 17:32:06 EDT
The printtools reports;
 
/dev/lp0 : Not detected
/dev/lp1 : Not detected
/dev/lp2 : Not detected

I have added "alias parport_lowlevel parport_pc to /etc/conf.modules
Changed the BIOS parallel port to EPP
The /var/log/messages reports lp: module loaded, but no devices found

Still no luck

Hardware is the following

ASUS TX4 Motherboard
Pentium MMX 166 Hz
17GB Fujitsu
128 MB RAM
Award Modular BIOS V4.51PG

Any suggestions?
Comment 1 Bernhard Rosenkraenzer 2000-06-26 13:44:05 EDT
Try loading the modules manually:
	insmod parport
	insmod parport_pc
	insmod lp
Then try to run a simple test:
	echo "Test Test Test" >/dev/lp0

and let me know the output of each of these commands.
Comment 2 ccraig1 2000-06-28 10:23:13 EDT
[root@localhost /root]# insmod paraport
[root@localhost /root]# insmod paraport_pc
/lib/modules/2.2.12-20/misc/parport_pc.0: init_module: Device or resource busy
[root@localhost /root]# insmod lp
[root@localhost /root]# echo Windows Sucks >/dev/lp0
bsah:/dev/lp0: No such device
Comment 3 Bernhard Rosenkraenzer 2000-07-25 10:16:43 EDT
This is all caused by the parport_pc module not being able to load...
do you get anything in /var/log/messages when you try to load the module?
What are the settings of your parallel port in the BIOS?
Comment 4 Michael K. Johnson 2000-08-07 23:22:35 EDT
Tim, do you have any ideas about what is going wrong here?
Comment 5 Tim Waugh 2000-08-08 05:03:48 EDT
parport_pc will fail to load if it can't see any ports at 0x278, 0x378, or
0x3bc, and there are no PCI parallel port cards it recognises.

So my guess is that your the motherboard is either using a really odd base
address for the port, or else it's using a normal address but the parallel port
chipset has read-only/write-only registers (possible, although I've only seen it
once before..).

Please do:

# dmesg -c
# modprobe parport_pc
# dmesg > out

and put the 'out' file in bugzilla.

In order to get your port working you might need to look up the base address in
the BIOS and put a line like this in your /etc/conf.modules:

options parport_pc io=0x378

(where 0x378 stands in for your parallel port's base address).

Also, you said that you set it to EPP mode; I've heard of screwy motherboard
that let you set EPP mode at 0x3bc, which just won't work.  Perhaps that's
what's happened? (If so, change either value.)
Comment 6 ccraig1 2000-11-06 13:43:41 EST
Update

I got the HP 690C to work using the following

PC BIOS setting 

Parallel Port Mode = Normal

The conf.modules files is as follows

Alias parport_lowlevel parport_pc
Options parport_pc io=0x378
Alias eth0 ne
Options ne io=0x300 irq=5

Please note that after I first logged the problem (12826) I reloaded Linux from 
scratch. I could not figure out how to install networking and wanted to redo 
the disk partitions also. Once I had finished re-installing the conf.modules 
file looked like this

Alias eth0 ne
Options ne io=0x300 irq=5

I then added the following two lines to the conf.modules

Alias parport_lowlevel parport_pc
Options parport_pc io=0x378

The conf.modules file then looked like this 

Alias eth0 ne
Options ne io=0x300 irq=5
Alias parport_lowlevel parport_pc
Options parport_pc io=0x378

BUT Linux could not detected /dev/lp0 etc

So I added the parport* lines first and then Linux was able to detect 
the  /dev/lp0








Note You need to log in before you can comment on or make changes to this bug.