Bug 1282604 - Improving rpc.gssd's debugging
Improving rpc.gssd's debugging
Status: CLOSED DUPLICATE of bug 1273163
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On: 1282600
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 16:12 EST by Steve Dickson
Modified: 2016-04-28 10:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282600
Environment:
Last Closed: 2016-04-28 10:52:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2015-11-16 16:12:55 EST
+++ This bug was initially created as a clone of Bug #1282600 +++

Description of problem:

Now that rpc.gssd is the critical path of every
NFS mount, any favored mount, I thought I would
take a crack at making the daemon a bit more 
debuggable by making the logging more readable.

The first level of debugging (-v) will only log 
errors and warnings that are not normally logged.
I'm thinking this might be a good level to run
at a customer's site.

I also thought about changing the majority of the 
printerr(0) which always log to printerr(1)s. I 
decided not to since I figured more info is 
better.

Note, I didn't remove any of the messages, I just pushed
them back to other debug levels. 

I trimmed down the second level of debugging (-vv) 
by again moving them back to other levels. 

The third level (-vvv) is basically the same.

Using the fourth level (-vvvv) to enable all the logging
that old level three did.

--- Additional comment from Steve Dickson on 2015-11-16 15:52:18 EST ---

Needed upstream commits:

commit 217a0ef3126ceb1126e3492e7b35cbb5596e13f6
Author: Steve Dickson <steved@redhat.com>
Date:   Sat Nov 7 12:51:37 2015 -0500

    gssd: reworked second level of debugging

commit 210a728b1ce99a6e59ed0d994eabc8ea90158729
Author: Steve Dickson <steved@redhat.com>
Date:   Sat Nov 7 11:31:40 2015 -0500

    gssd: log all fatal errors

commit 4eb495c8eeb2dd3183b4dbc0a238c8e0e76e9237
Author: Steve Dickson <steved@redhat.com>
Date:   Sat Nov 7 11:24:30 2015 -0500

    gssd: reworked first level of debugging

--- Additional comment from Steve Dickson on 2015-11-16 16:12:04 EST ---

(In reply to Steve Dickson from comment #1)
> Needed upstream commits:
These are the real commits ids:

commit be40202f194877306c19929479114b90a08363c1
Author: Steve Dickson <steved@redhat.com>
Date:   Sat Nov 7 12:51:37 2015 -0500

    gssd: reworked second level of debugging


commit f1172857775d7be47b9ffb51825001cf39e23e70
Author: Steve Dickson <steved@redhat.com>
Date:   Sat Nov 7 11:31:40 2015 -0500

    gssd: log all fatal errors
    
    When gssd exist ensure a error message is logged.
    
    Signed-off-by: Steve Dickson <steved@redhat.com>

commit 329d4685ace7659a50517cc2f4d8c926d6aec500
Author: Steve Dickson <steved@redhat.com>
Date:   Sat Nov 7 11:24:30 2015 -0500

    gssd: reworked first level of debugging
Comment 2 Steve Dickson 2016-04-28 10:52:33 EDT

*** This bug has been marked as a duplicate of bug 1273163 ***

Note You need to log in before you can comment on or make changes to this bug.