Bug 1282610 - A long package description makes window of Gnome Software too large for the screen
A long package description makes window of Gnome Software too large for the s...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 16:37 EST by Марко М. Костић (Marko M. Kostić)
Modified: 2015-12-03 11:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 11:56:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gnome Software window when BricsCAD RPM is opened in it. (1.03 MB, image/png)
2015-11-16 16:37 EST, Марко М. Костић (Marko M. Kostić)
no flags Details

  None (edit)
Description Марко М. Костић (Marko M. Kostić) 2015-11-16 16:37:51 EST
Created attachment 1095107 [details]
Gnome Software window when BricsCAD RPM is opened in it.

Description of problem:

When I try to install BricsCAD RPM package via Gnome Software, it's long description makes the Gnome Software window very large (see attachement).

Version-Release number of selected component (if applicable):
gnome-software.x86_64                 3.18.3-1.fc23


How reproducible:
Always.

Steps to Reproduce:
1. Register and download BricsCAD from http://www.bricsys.com/en_INTL/bricscad/# (there is a 30 day trial option)
2. Navigate to the directory where RPM was downloaded.
3. Open the RPM package in Gnome Software.

Actual results:
The window becomes very large because package description read from the RPM isn't wraped.

Expected results:
The package description does not alter the window size.
Comment 1 Rafal Luzynski 2015-12-01 19:51:14 EST
Thank you for spotting this bug, Marko. It's been fixed upstream: https://git.gnome.org/browse/gnome-software/commit/?id=af86231
Comment 2 Марко М. Костић (Marko M. Kostić) 2015-12-03 11:56:14 EST
That's great!

Note You need to log in before you can comment on or make changes to this bug.