Bug 128262 - ldconfig symlink libtiff.so.3 missing for i386 compatibility on ia64
ldconfig symlink libtiff.so.3 missing for i386 compatibility on ia64
Status: CLOSED DUPLICATE of bug 126905
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: libtiff (Show other bugs)
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Depends On:
  Show dependency treegraph
Reported: 2004-07-20 18:10 EDT by Geoff Gustafson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2004-07-20 18:10:56 EDT
Description of problem:
[Probably doesn't belong under libtiff but I didn't know where to file

Trying to run a 32-bit ppm2tiff on ia64 with ia32el (U3-0715), it
couldn't find the library libtiff.so.3, which is supposed to be a
symlink to libtiff.so.3.5.

After manually creating the link, 32-bit ppm2tiff works fine.

Running the /emul/ia32-linux/sbin/ldconfig yields some errors of this
./sbin/ldconfig: libraries libtiff.so.3 and libtiff.so.3.5 in
directory /usr/lib have same soname but different type.

Apparently it is looking in the real /usr/lib since that is where
libtiff.so.3 is present. Running the 64-bit ldconfig, passing in the
directory /emul/ia32-linux/usr/lib, creates the libtiff.so.3
correctly, and then the 32-bit ppm2tiff works. Here's the full list of
missing symlinks it adds (on an 'everything' install + ia32el):

Passing in /emul/ia32-linux/usr/lib:
> libg++.so.2.7.2
> libstdc++-libc6.1-1.so.2
> libstdc++.so.2.7.2
> libstdc++.so.2.8
> libstdc++.so.2.9
> libtiff.so.3

Passing in /emul/ia32-linux/lib:
> libcrypto.so.2
> libcrypto.so.4
> libdb.so.3
> libnss_ldap.so.2
> libpamc.so.0
> libpam_misc.so.0
> libpam.so.0
> libssl.so.2
> libssl.so.4

Version-Release number of selected component (if applicable):

Additional info:
It seems to me maybe ldconfig needs to be run again at the end of the
install. I know nothing about how that is handled in install, except
that it's common for rpm scripts to run ldconfig. Maybe the relevant
rpms are running the 32-bit version of ldconfig, and since it has
issues, the links aren't getting created, in which case maybe the
clean fix is in ldconfig?

Maybe /emul/ia32-linux/lib and .../usr/lib should be added to the main
Comment 1 Jay Turner 2004-07-20 20:48:25 EDT

*** This bug has been marked as a duplicate of 126905 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.