Bug 1282623 - apache-jasper specifically requires java-1.6.0
apache-jasper specifically requires java-1.6.0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: apache-jasper (Show other bugs)
6.8
All Linux
high Severity medium
: rc
: ---
Assigned To: Jeff Johnston
Jan Ščotka
:
Depends On:
Blocks: 1269194 1271375
  Show dependency treegraph
 
Reported: 2015-11-16 17:26 EST by Michael Simacek
Modified: 2017-03-21 07:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: apache-jasper-5.5.28-4.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 07:37:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Simacek 2015-11-16 17:26:05 EST
Description of problem:
apache-jasper has Requires: java-1.6.0-devel, even though it should work with newer versions of java. 

Version-Release number of selected component (if applicable):
apache-jasper-5.5.28-3

How reproducible:
always

Steps to Reproduce:
1. yum -y install java-1.7.0 java-1.7.0-devel
2. yum -y install apache-jasper

Actual results:
java-1.6.0-openjdk is installed as a dependency

Expected results:
no java 6 runtime installed

Additional info:
Comment 3 Alexander Kurtakov 2015-11-20 03:21:54 EST
From communication with Java maint and OpenJDK teams - "apache-jasper  will need to  requires java-1.7.0-devel directly" due to concerns over OpenJDK 1.7 providing java-devel.
Comment 5 Jeff Johnston 2016-01-25 12:18:16 EST
I have a scratch-build: https://brewweb.devel.redhat.com/taskinfo?taskID=10388829 which has fixed the problem using the new buildroot and setting the BR and R to use java-devel.
Comment 6 mbenitez 2016-02-25 10:07:28 EST
Moving out to RHEL 6.9 for re-evaluation
Comment 10 Jeff Johnston 2016-11-01 15:34:03 EDT
Patch has been built into:  apache-jasper-5.5.28-4.el6
Comment 14 errata-xmlrpc 2017-03-21 07:37:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0764.html

Note You need to log in before you can comment on or make changes to this bug.