Bug 1282626 - Terminal multiplexers (tmux, screen) are broken in systemd-nspawn containers (F22 > F23 regression)
Terminal multiplexers (tmux, screen) are broken in systemd-nspawn containers ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 17:29 EST by Sylvain Pasche
Modified: 2016-01-10 14:24 EST (History)
6 users (show)

See Also:
Fixed In Version: systemd-222-12.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-10 14:24:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sylvain Pasche 2015-11-16 17:29:08 EST
Description of problem:

systemd 222 on Fedora 23 is affected by this issue: https://github.com/systemd/systemd/issues/337 (which has been fixed upstream since then).

As a consequence, you can't run tmux or screen as a user inside a systemd-nspawn container. It used to work fine on Fedora 22.

It would be nice if the patch from https://github.com/systemd/systemd/issues/337 could be backported on f23 to avoid breaking that workflow.

I tried backporting this patch on top of 222-8 and I can confirm it fixes the issue:
https://github.com/systemd/systemd/commit/0ed5c799a6ac69b15d11e107994fec1fc49b40fd
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-16 18:51:35 EST
Yeah.
Comment 2 Fedora Update System 2016-01-08 04:48:14 EST
systemd-222-12.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aae4b3b916
Comment 3 Fedora Update System 2016-01-08 23:27:22 EST
systemd-222-12.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aae4b3b916
Comment 4 Fedora Update System 2016-01-10 14:24:08 EST
systemd-222-12.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.