Bug 1282658 - fv_network test fail - guest network test is incomplete
fv_network test fail - guest network test is incomplete
Status: CLOSED ERRATA
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 20:25 EST by Greg Nichols
Modified: 2016-02-16 04:32 EST (History)
1 user (show)

See Also:
Fixed In Version: redhat-certification-2.1-20150919
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 04:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server/wsgi/save.py fixing sever response (763 bytes, patch)
2015-11-16 20:35 EST, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2015-11-16 20:25:59 EST
Description of problem:

The fv_network test fails with the guest's network test incomplete.

On the guest, the log of the network test's http transfer portion has a traceback:

Subtest: HTTP - HTTP file transfer test
sending file /var/www/html/httptest.file hash: 23601c656bbb6f484b871c78c5df8f12
response: 
/var/www/rhcert/store/transfer/10.10.176.21/httptest.file
Upload took 0.12 seconds, 17.11 MB/sec
Warning: could not read upload IP address from response, assuming device IP address
getting file http://ceph2.hq.gsslab.rdu.redhat.com/hwcert/transfer/192.168.122.76/httptest.file 
Traceback (most recent call last):
  File "/usr/bin/hwcert-backend", line 45, in <module>
    success = hwcertBackend.do(args)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 182, in do
    result = self.commands[self.command]()
  File "/usr/share/hwcert/lib/hwcert/harness.py", line 357, in doRun
    return self._doRun(tests)
  File "/usr/share/hwcert/lib/hwcert/harness.py", line 465, in _doRun
    returnValue = self.runTest(tmpDirectory, test, run, outputFilePath)
  File "/usr/share/hwcert/lib/hwcert/harness.py", line 906, in runTest
    rv = test.run()
  File "/usr/share/hwcert/lib/hwcert/networkTest.py", line 775, in run
    if not self.runSubTest(self.httpTransferTest, "HTTP", "HTTP file transfer test"):
  File "/usr/share/hwcert/lib/hwcert/test.py", line 471, in runSubTest
    result = subtestFunction()
  File "/usr/share/hwcert/lib/hwcert/networkTest.py", line 639, in httpTransferTest
    receivedFileCheckSum = self.httpDownload(uploadIPAddress)
  File "/usr/share/hwcert/lib/hwcert/networkTest.py", line 693, in httpDownload
    response = opener.open(request).read()
  File "/usr/lib64/python2.6/urllib2.py", line 397, in open
    response = meth(req, response)
  File "/usr/lib64/python2.6/urllib2.py", line 510, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib64/python2.6/urllib2.py", line 435, in error
    return self._call_chain(*args)
  File "/usr/lib64/python2.6/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib64/python2.6/urllib2.py", line 518, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found

This happens because the test running on the guest is looking for a response from the test server of the form:

pattern = re.compile("Saving File From IP: [ \t]*(?P<address>[^\s]*)")

(hwcert/hwcert.networkTest.py line 559 from hwcert-client 1.6.5.2)

But the response from an rhcert 2.0 server is:

/var/www/rhcert/store/transfer/10.10.176.21/httptest.file

Note that the guest sees it's address as 192.168.122.76, but it's address as seen by the server is 10.10.176.21


Version-Release number of selected component (if applicable):

redhat-certification-2.0-20151116.el7.noarch
redhat-certification-information-1.7.1-20151113.el7.noarch
redhat-certification-backend-2.0-20151116.el7.noarch
redhat-certification-hardware-1.7.1-20151113.el7.noarch

Guest image (data) has hwcert-client-1.6.5.2
Comment 1 Greg Nichols 2015-11-16 20:35 EST
Created attachment 1095164 [details]
server/wsgi/save.py fixing sever response

The patch retro-fits the old server response for rhecert-2.0
Comment 4 Brian Brock 2016-01-06 16:00:50 EST
verified in 
redhat-certification-2.1-20151221.el7.noarch
redhat-certification-hardware-1.7.1-20151218.el7.noarch

fv_network test passes without complaint
Comment 7 errata-xmlrpc 2016-02-16 04:32:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0196.html

Note You need to log in before you can comment on or make changes to this bug.