Bug 1282668 - The release of qt-creator in the repo is out of sync with the release of the qt5 rpms in the EPEL-6 repo
The release of qt-creator in the repo is out of sync with the release of the ...
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: qt-creator (Show other bugs)
el6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dave Johansen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 21:22 EST by Jeff Sampson
Modified: 2016-09-08 09:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Sampson 2015-11-16 21:22:41 EST
Description of problem:
The release of qt-creator in the repo is out of sync with the release of the qt5 rpms in the EPEL repo.  Please update it.

Version-Release number of selected component (if applicable):
3.0.1-3

Additional info:
See https://blog.qt.io/blog/2015/10/15/qt-5-5-1-released/ for more information.  Qt 5.5.1 comes with Qt Creator 3.5.1.
Comment 1 Dave Johansen 2015-11-17 10:03:49 EST
In my mind this is against the update policy, but since the Qt 5 package is being updated, I'll check on the mailing list to see if everyone is ok with me updating Qt Creator as well ( https://lists.fedoraproject.org/pipermail/epel-devel/2015-November/011785.html ).
Comment 2 Itamar Reis Peixoto 2015-11-17 11:17:33 EST
+1 for the upgrade, remember that EPEL repo will be always behind.
Comment 3 Yaakov Selkowitz 2015-12-11 01:31:19 EST
Furthermore, qt-creator-3.0.1 FTBFS with Qt 5.5, so updating qt-creator is also required for the new epel7 arches which are being built for the first time.
Comment 4 Rex Dieter 2016-02-15 09:36:32 EST
fyi, epel will likely get at least one more Qt5 update to 5.6.0 (when available soon), and then we (Qt5 maintainers) will likely keep epel on 5.6.x series, since it will be an LTS supported release.
Comment 5 Rex Dieter 2016-03-21 13:06:30 EDT
OK, Qt-5.6.0 is about to get submitted to bodhi for both epel-7 and el6:

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-875ec6d2b3

and

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-eada5cb858

respectively.

and Qt-5.6.0 packages are tagged as buildroot overrides until Fri Mar 25.

Let me know how you (qt-creator EPEL maintainers) want to handle this.   In particular, if you do any qt-creator builds, and want me to add to the above updates.

Thanks.
Comment 6 Dave Johansen 2016-03-21 13:43:12 EDT
If you're willing to do the rebase/rebuild qt-creator for EPEL, then I'd appreciate it.
Thanks.
Comment 7 Rex Dieter 2016-03-21 14:35:33 EDT
OK, looking at it for a few minutes, ran into snag that newer qt-creator (3.6.x) seems to want a newer llvm than either el7 or el6 provides

next attempt: see if existing older qt-creator is (re)buildable against qt-5.6
Comment 8 Rex Dieter 2016-03-21 14:36:38 EDT
oh, nevermind, comment #3 implies *something* newer is required, so maybe something in between 3.0 and 3.6 can work.
Comment 9 Rex Dieter 2016-03-21 16:31:16 EDT
qt-creator-3.5.x needs gcc-4.7, so that's not an option for epel either, and starting to think qt-creator may be unsupportable


Making a copr that can use:
https://www.softwarecollections.org/en/scls/rhscl/devtoolset-3/
(and it's newer compilers) may be an option.
Comment 10 John Hodrien 2016-04-07 11:18:24 EDT
It puts EPEL in an unhappy place, as a machine with qt-creator installed can't be upgraded and throws errors due to qt-creator requiring an older qt5-qtbase.  A qt-creator than is happy with qt-5.6 seems like a very desirable thing.
Comment 11 Rex Dieter 2016-04-07 11:25:10 EDT
Adjusting summary to make it clear this only affects epel-6

Any qt-creator maintainers object to the plan of (essentially) retiring qt-creator from epel-6 ?

(if so, do you have any better ideas, other than providing qt-creator via copr?)
Comment 12 John Hodrien 2016-04-07 11:28:42 EDT
This issue of it being out of sync affects epel-7 too now that 5.6 is out, no?  Do you just mean this bug is only addressing epel-6, and we should open a separate bug?
Comment 13 Dave Johansen 2016-04-07 11:29:52 EDT
(In reply to Rex Dieter from comment #11)
> Adjusting summary to make it clear this only affects epel-6
> 
> Any qt-creator maintainers object to the plan of (essentially) retiring
> qt-creator from epel-6 ?
> 
> (if so, do you have any better ideas, other than providing qt-creator via
> copr?)

We've begun the upgrade to EL 7 so retiring it from EL 6 wouldn't really effect us, but I feel bad for all of the people out there still using EL 6 that have a very useful tool ripped out from underneath them. Can an older version be rebuilt against the new Qt 5 release for EL 6?
Comment 14 Dave Johansen 2016-04-07 11:36:44 EDT
(In reply to Rex Dieter from comment #7)
> OK, looking at it for a few minutes, ran into snag that newer qt-creator
> (3.6.x) seems to want a newer llvm than either el7 or el6 provides
> 
> next attempt: see if existing older qt-creator is (re)buildable against
> qt-5.6

I've been thinking about updating the version of llvm/clang in EPEL 7. Would this be an additional motivation to do something like that?
Comment 15 Rex Dieter 2016-04-07 11:42:05 EDT
fyi, epel-7 qt-5.6.x compatible qt-creator update is here:
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-ed8d118583

(mostly an oversight of mine that it didn't get pushed along with qt-5.6),

see also bug #1324302
Comment 16 Rex Dieter 2016-09-08 09:54:06 EDT
Dave,
I think the best way forward would be to simply retire qt-creator from epel-6 repo  

It may be possible to bring back a newer version in copr using devtoolset if anyone is interested in working on that.

Note You need to log in before you can comment on or make changes to this bug.