Bug 1282679 - Can't configure multiple bonds with dracut bond=
Can't configure multiple bonds with dracut bond=
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukáš Nykrýn
Release Test Team
:
Depends On:
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-11-16 23:45 EST by Derek Schrock
Modified: 2016-11-04 04:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:00:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Write bond.NAME.info files per bond= (1.35 KB, application/mbox)
2015-11-16 23:45 EST, Derek Schrock
no flags Details

  None (edit)
Description Derek Schrock 2015-11-16 23:45:38 EST
Created attachment 1095219 [details]
Write bond.NAME.info files per bond=

Description of problem:

When you have multiple bond= options set only one bond is configured:

   ... rd.neednet=1 bond=bond0:ens1,ens3 bond=bond1:ens2,ens4 ip=bond0:dhcp ip=bond1:dhcp ...

During installation and after reboot only one of the bonds will be created.  I believe it will always be bond0 or depending on locale.

Version-Release number of selected component (if applicable):
RHEL 7.1 media dracut initrd.img


How reproducible:
Set the above boot options during installation.


Actual results:
Only one bond is created

Expected results:
Multiple bond interfaces to be created

Additional info:
See attached patch for dracut parse-bond.sh
Comment 2 Brendan Germain 2016-05-08 18:04:59 EDT
Also experiencing this problem and need the functionality of being able to create multiple bonds. Is there any update for this?

Thanks.
Comment 4 Peter Kotvan 2016-08-05 09:19:31 EDT
Verified on RHEL-7.3-20160729.1 with RHEL-7.3-20160729.1.
Comment 7 errata-xmlrpc 2016-11-04 04:00:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html

Note You need to log in before you can comment on or make changes to this bug.