Bug 1282680 - If a team or bond interface is configured via dracut boot options all non-team/bond interfaces are not configured
Summary: If a team or bond interface is configured via dracut boot options all non-tea...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1289485 1313485
TreeView+ depends on / blocked
 
Reported: 2015-11-17 05:02 UTC by Derek Schrock
Modified: 2016-11-04 08:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 08:01:02 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2530 normal SHIPPED_LIVE dracut bug fix and enhancement update 2016-11-03 14:17:01 UTC

Description Derek Schrock 2015-11-17 05:02:41 UTC
Description of problem:

When creating a bond or team interfaces via dracut boot options all non-team/bond interfaces are not created:

 ... rd.neednet=1 bond=bond0:ens1,ens3 ip=bond0:dhcp ip=192.168.100.100::192.168.100.1:255.255.255.0::ens2:none ...

Version-Release number of selected component (if applicable):

RHEL 7.1 dracut initrd.img


How reproducible:

Boot with the above options


Actual results:
Only bond0 is configured

Expected results:
All interfaces (bond0,ens2) be configured.

Comment 3 Peter Kotvan 2016-08-05 13:04:51 UTC
Verified on RHEL-7.3-20160729.1 with RHEL-7.3-20160729.1.

Comment 6 errata-xmlrpc 2016-11-04 08:01:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html


Note You need to log in before you can comment on or make changes to this bug.