Bug 128269 - mkisofs drops permissions in -udf filesystems
Summary: mkisofs drops permissions in -udf filesystems
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrtools   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-20 23:17 UTC by Greg Hartman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 11:01:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to set permissions in UDF (4.87 KB, patch)
2004-07-20 23:20 UTC, Greg Hartman
no flags Details | Diff

Description Greg Hartman 2004-07-20 23:17:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
mkisofs uses default permissions when building UDF filesystems. This
causes problems for me, since I need to be able to set the executable
bit on some files. I worked around this with the attached patch. Is
there any way that this patch or something similar could end up in
future releases?

Version-Release number of selected component (if applicable):
mkisofs-2.01-0.a27.4.FC2.1

How reproducible:
Always

Steps to Reproduce:
1. mkdir /tmp/cdimage
2. touch /tmp/cdimage/noexec
3. touch /tmp/cdimage/exec
4. chmod +x /tmp/cdimage/exec
5. mkisofs -o /tmp/out.udf --udf -V mervid -graft-points /=/tmp/cdimage
6. mkdir -p /mnt/temp
7. mount -oro,loop -tudf /tmp/out.udf /mnt/temp
8. ls -l /mnt/temp
    

Actual Results:  -r--r--r--  1 4294967295 4294967295 0 Jul 20 19:14 exec
-r--r--r--  1 4294967295 4294967295 0 Jul 20 19:14 noexec


Expected Results:  -r-xr-xr-x  1 root root 0 Jul 20 19:15 exec
-r--r--r--  1 root root 0 Jul 20 19:15 noexec


Additional info:

This was already a documented bug in mkisofs. The author mentions that
using the Rock Ridge attributes would be a viable workaround. I
decided to avoid this and just do another lstat on the files; the Rock
Ridge attributes don't seem to be present when the -R option isn't used.

I still use the dummy uid, gid, and modes for the root directory. I
don't know what to stat in most cases.

The disclaimers on the man should also be updated.

Comment 1 Greg Hartman 2004-07-20 23:20:14 UTC
Created attachment 102087 [details]
Patch to set permissions in UDF

Comment 2 Harald Hoyer 2004-07-28 11:03:41 UTC
notified upstream author


Note You need to log in before you can comment on or make changes to this bug.