Bug 1282699 - vmcore cannot be generated if noauto is set for dump target which is local disk
vmcore cannot be generated if noauto is set for dump target which is local disk
Status: CLOSED DUPLICATE of bug 1186708
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.1
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: kdump team
Kernel General QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 02:24 EST by shiwang
Modified: 2015-11-17 03:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 03:20:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shiwang 2015-11-17 02:24:25 EST
Description of problem:

Vmcore cannot be generated if noauto is set for dump target which is local disk.
The customer don't want to mount kdump dump target at boot. So he need to use
noauto option for the dump target device. But after using it, vmcore cannot be
generated.

Version-Release number of selected component (if applicable):

kexec-tools-2.0.7-19.el7.x86_64
kernel 3.10.0-229.7.2.el7.x86_64

How reproducible:

Steps to Reproduce:

1. add an additional disk (/dev/sdb)

2. set the disk as dump target

#cat /etc/kdump.conf
xfs UUID="0603cfba-c0c6-4bf2-8ed0-a0cae32aeafe"
path /var/crash
core_collector makedumpfile -l --message-level 1 -d 31

#blkid
/dev/sdb: UUID="0603cfba-c0c6-4bf2-8ed0-a0cae32aeafe" TYPE="xfs" 

3. set the disk into /etc/fstab

#cat /etc/fstab
UUID=0603cfba-c0c6-4bf2-8ed0-a0cae32aeafe /dump     xfs defaults,noauto 0 0

4. mount the /dev/sdb in order to create initrd for kdump.

#mount /dev/sdb

5. recreate the kdump initrd file.

#kdumpctl restart

6. umount the /dev/sdb

#umount /dev/sdb

7. Trigger the kernel panic

#echo c > /proc/sysrq-trigger

8. After reboot, mount the /dev/sdb and check the result.

Actual results:

No vmcore files.

Expected results:

vmcore and vmcore-dmesg.txt files exist.

Additional info:

I tested it with same procedure as above using RHEL7.0 and it works fine.

kexec-tools-2.0.4-32.el7.x86_64
kernel 3.10.0-123.el7.x86_64

My question is, do we need to mount kdump dump target at boot time in order 
to generate vmcore? Is it a change recently?

Best regards
Shiyu Wang
Technical Support Engineer
Comment 2 Minfei Huang 2015-11-17 02:43:47 EST
Hi.

This bug is fixed in version 2.0.7-26. Maybe you can try kexec-tool version 2.0.7-26 or later.

Thanks
Minfei
Comment 4 shiwang 2015-11-17 03:20:05 EST
Hi All,

Thank you very much! It works in 2.0.7-26. I will close this BUG.

BR,
Shiwang

*** This bug has been marked as a duplicate of bug 1186708 ***

Note You need to log in before you can comment on or make changes to this bug.