Bug 1282732 - virt-builder can't resize debian-8 images
virt-builder can't resize debian-8 images
Status: CLOSED DUPLICATE of bug 1266658
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 04:27 EST by Marius Vollmer
Modified: 2015-11-17 04:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 04:55:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Vollmer 2015-11-17 04:27:19 EST
This fails:

$ virt-builder --format qcow2 --size 10G --root-password=password:foobar debian-8
[   5,2] Downloading: http://libguestfs.org/download/builder/debian-8.xz
[   5,8] Planning how to build this image
[   5,8] Uncompressing
[  15,0] Resizing (using virt-resize) to expand the disk to 10,0G
virt-resize: error: libguestfs error: part_set_mbr_id: sfdisk --part-type: 
Extended partition already exists.
sfdisk: /dev/sdb: partition 2: failed to set partition type

If reporting bugs, run virt-resize with debugging enabled and include the 
complete output:

  virt-resize -v -x [...]

Version-Release number of selected component (if applicable):
libguestfs-tools-c-1.30.4-1.fc22.x86_64

How reproducible:
Always
Comment 1 Richard W.M. Jones 2015-11-17 04:55:34 EST
This is fixed upstream but the fixes haven't been backported to
the 1.30 branch (yet).  See:
https://bugzilla.redhat.com/show_bug.cgi?id=1266658#c4

*** This bug has been marked as a duplicate of bug 1266658 ***

Note You need to log in before you can comment on or make changes to this bug.