Bug 1282764 - [RFE][scale] Visualize the number of queued SPM calls on RHEV-M in the logs
[RFE][scale] Visualize the number of queued SPM calls on RHEV-M in the logs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.5.3
All Linux
medium Severity medium
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Liron Aravot
Eldad Marciano
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 06:02 EST by Tim Speetjens
Modified: 2016-08-23 16:30 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:30:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Engine.log DEBUG log level (919.57 KB, application/x-gzip)
2016-07-19 09:52 EDT, Yuri Obshansky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48245 master MERGED infra/storage: send commands to the SPM on a FIFO basis 2016-06-05 08:42 EDT
oVirt gerrit 58667 ovirt-engine-4.0 MERGED infra/storage: send commands to the SPM on a FIFO basis 2016-06-06 12:25 EDT

  None (edit)
Description Tim Speetjens 2015-11-17 06:02:33 EST
Description of problem:

When using RHEV for a test lab, where each test involves the creation of, and then the removal of a VM, the API allows for loading the environment heavily, including storage. For this use case, the goal is to load the environment, but to keep it running stable.

When storage is loaded and responds slower than usual, the requests may be queued on the manager. The logs do not contain information, to get an idea about this, easily.

This RFE is about adding information in the engine log file, when requests to the SPM are queued until other requests return.

Version-Release number of selected component (if applicable):

RHEV 3.5.3

How reproducible:
Running storage tasks in parallel

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This request is related to the following issues:
bz#1275736 - Transaction scope is too large for SPM commands
bz#1277057 - Unfair queuing mechanism on the manager for handling SPM requests
Comment 4 Liron Aravot 2016-06-06 14:04:13 EDT
A log was added in DEBUG logging mode.
Comment 5 Yuri Obshansky 2016-07-19 09:51:07 EDT
Bug[RFE] verified on RHEVM - 4.0.2-0.2.rc1.el7ev
Changed engine log level to DEBUG
Ran REST API script which removes templates using 5 concurrent threads.
We can see expected messages in engine.log file such as:
2016-07-19 09:05:05,396 DEBUG [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData] (org.ovirt.thread.pool-6-thread-9) [29f4512] Waiting on other task to finish (0 additional threads are queued)
..or...
2016-07-19 09:05:05,397 DEBUG [org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData] (org.ovirt.thread.pool-6-thread-15) [6fa566a6] Waiting on other task to finish (1 additional threads are queued)
...etc
Attached engine.log file 
Test started at 2016-07-19 09:04:54
I think,we can closed bug.

Yuri
Comment 6 Yuri Obshansky 2016-07-19 09:52 EDT
Created attachment 1181643 [details]
Engine.log DEBUG log level
Comment 8 errata-xmlrpc 2016-08-23 16:30:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.