Bug 1282816 - Add a function gnutls_x509_crt_key_encrypt
Add a function gnutls_x509_crt_key_encrypt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikos Mavrogiannopoulos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 09:12 EST by Andreas Schneider
Modified: 2015-11-18 02:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 02:33:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Schneider 2015-11-17 09:12:54 EST
Please proivde a function gnutls_x509_crt_key_encrypt() which uses the subjectPublicKey to encrypt the given data.

gnutls_x509_crt_key_encrypt(gnutls_x509_crt_t cert,
                            const void * ptext, size_t ptext_len,
                            void * ctext, size_t ctext_len);

or a way to extract the public key so you can do it with the public key API.

This is needed to implement the MS-BRKP protocol in Samba with GnuTLS.
Comment 1 Andreas Schneider 2015-11-17 09:44:01 EST
It is the other way around. Looks like gnutls_pubkey_import_x509() imports the sPKI of the cert. However encryption fails doesn't work, need to check why ...

Note You need to log in before you can comment on or make changes to this bug.