Bug 1282829 - perl-File-RsyncP-0.74-1 build failed on ppc64le epel7
perl-File-RsyncP-0.74-1 build failed on ppc64le epel7
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: perl-File-RsyncP (Show other bugs)
epel7
ppc64le Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7ppc64le
  Show dependency treegraph
 
Reported: 2015-11-17 09:54 EST by Menanteau Guy
Modified: 2016-06-20 06:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-File-RsyncP-0.74-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-20 06:20:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Menanteau Guy 2015-11-17 09:54:19 EST
build of perl-File-RsyncP-0.74-1 failed on an epel7 ppc64le local environment using a RHEL7.2 snapshot of the 15th of october 2015.

configure: error: cannot guess build type; you must specify one

This happened because of following line in the spec:
cp /usr/lib/rpm/config.* FileList/

Because of the rpm-4.11.3-17 package version on redhat, /usr/lib/rpm/config.guess and config.sub comming from rpm package are not set correctly for ppc64le and these files can not be used directly. 
Note that /usr/lib/rpm/redhat/config... handle ppc64le correctly.
Comment 1 Petr Šabata 2015-11-20 06:40:31 EST
Okay, I switched to the configuration provided by redhat-rpm-config.
Comment 2 Fedora Update System 2015-11-20 06:45:25 EST
perl-File-RsyncP-0.74-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-2e427ffc13
Comment 3 Fedora Update System 2015-11-21 15:52:54 EST
perl-File-RsyncP-0.74-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update perl-File-RsyncP'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-2e427ffc13
Comment 4 Fedora Update System 2015-12-08 01:25:59 EST
perl-File-RsyncP-0.74-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.