Bug 1282848 - thunderbird-lightning-3.3-5 build failed on ppc64le/aarch64
thunderbird-lightning-3.3-5 build failed on ppc64le/aarch64
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: thunderbird-lightning (Show other bugs)
epel7
ppc64le Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7ppc64le epel7aarch64
  Show dependency treegraph
 
Reported: 2015-11-17 10:53 EST by Menanteau Guy
Modified: 2015-11-25 22:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 22:19:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Menanteau Guy 2015-11-17 10:53:01 EST
build of thunderbird-lightning-3.3-5 failed on an epel7 ppc64le local environment using a RHEL7.2 snapshot of the 15th of october 2015.

configure: error: cannot guess build type; you must specify one

This happened because of following line in the spec:
# Update the various config.guess to upstream release for aarch64 support
find ./ -name config.guess -exec cp /usr/lib/rpm/config.guess {} ';'

Because of the rpm-4.11.3-17 package version on redhat, /usr/lib/rpm/config.guess and config.sub comming from rpm package are not set correctly for ppc64le and these files can not be used directly. 
Note that /usr/lib/rpm/redhat/config... handle ppc64le correctly.
Comment 1 Yaakov Selkowitz 2015-11-25 22:00:01 EST
thunderbird 38, which has been released as an errata for both RHEL and CentOS, will obsolete thunderbird-lightning.  Therefore, AFAICS epel7 thunderbird-lightning should be retired.
Comment 2 Orion Poplawski 2015-11-25 22:19:54 EST
Indeed.  Done.

Note You need to log in before you can comment on or make changes to this bug.