Bug 1282878 - Fleecing rhos4 instances throws "MIQExtract.extract undefined method `vmConfig' for #<MiqOpenStackInstance:0x0000000a5ba590>" error
Fleecing rhos4 instances throws "MIQExtract.extract undefined method `vmConfi...
Status: CLOSED DUPLICATE of bug 1279508
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Rich Oliveri
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 12:18 EST by Ramesh A
Modified: 2015-11-17 12:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 12:57:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SSA - task page (67.01 KB, image/png)
2015-11-17 12:18 EST, Ramesh A
no flags Details

  None (edit)
Description Ramesh A 2015-11-17 12:18:13 EST
Created attachment 1095567 [details]
SSA - task page

Description of problem:
Fleecing rhos4 instances throws "MIQExtract.extract undefined method `vmConfig' for #<MiqOpenStackInstance:0x0000000a5ba590>" error in evm.log file

Version-Release number of selected component (if applicable):
5.5.0.10-beta2.1.20151110134042_d6f5459

How reproducible:
Very

Steps to Reproduce:
1. Deploy an appliance and manage rhos4 provider
2. Configure for SSA
3. Perform SSA on any instance

Actual results:
Throws error in evm.log file, but gets successfully completed in the Configure ==> Tasks page.  Refer the screenshot for further information.

Expected results:
should not throw any error message

Additional info:
evm.log:
========
[----] I, [2015-11-17T10:30:23.674355 #22094:59d990]  INFO -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::EventCatcher::Runner#do_work) EMS [10.8.58.49] as [admin] Event Monitor Thread gone. Restarting...
[----] E, [2015-11-17T10:30:25.055318 #5390:f03994] ERROR -- : MIQExtract.extract undefined method `vmConfig' for #<MiqOpenStackInstance:0x0000000a5ba590>
[----] E, [2015-11-17T10:30:25.056689 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/gems/pending/OpenStackExtract/MiqOpenStackVm/MiqOpenStackInstance.rb:191:in `method_missing'
[----] E, [2015-11-17T10:30:25.056770 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/gems/pending/metadata/MIQExtract/MIQExtract.rb:162:in `getVMConfig'
[----] E, [2015-11-17T10:30:25.056834 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/gems/pending/metadata/MIQExtract/MIQExtract.rb:139:in `block in extract'
[----] E, [2015-11-17T10:30:25.056903 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/gems/pending/metadata/MIQExtract/MIQExtract.rb:131:in `each'
[----] E, [2015-11-17T10:30:25.056979 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/gems/pending/metadata/MIQExtract/MIQExtract.rb:131:in `extract'
[----] E, [2015-11-17T10:30:25.057124 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/mixins/scanning_mixin.rb:254:in `block in scan_via_miq_vm'
[----] E, [2015-11-17T10:30:25.057222 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/mixins/scanning_mixin.rb:250:in `each'
[----] E, [2015-11-17T10:30:25.057327 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/mixins/scanning_mixin.rb:250:in `scan_via_miq_vm'
[----] E, [2015-11-17T10:30:25.057409 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/manageiq/providers/openstack/cloud_manager/vm.rb:49:in `perform_metadata_scan'
[----] E, [2015-11-17T10:30:25.057493 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_server/server_smart_proxy.rb:123:in `scan_metadata'
[----] E, [2015-11-17T10:30:25.057571 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
[----] E, [2015-11-17T10:30:25.057662 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
[----] E, [2015-11-17T10:30:25.057742 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
[----] E, [2015-11-17T10:30:25.057821 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
[----] E, [2015-11-17T10:30:25.057908 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
[----] E, [2015-11-17T10:30:25.057989 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
[----] E, [2015-11-17T10:30:25.058135 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
[----] E, [2015-11-17T10:30:25.058225 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
[----] E, [2015-11-17T10:30:25.058308 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
[----] E, [2015-11-17T10:30:25.058391 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
[----] E, [2015-11-17T10:30:25.058483 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
[----] E, [2015-11-17T10:30:25.058562 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
[----] E, [2015-11-17T10:30:25.058657 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:334:in `block in do_work_loop'
[----] E, [2015-11-17T10:30:25.058742 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `loop'
[----] E, [2015-11-17T10:30:25.058826 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `do_work_loop'
[----] E, [2015-11-17T10:30:25.058908 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
[----] E, [2015-11-17T10:30:25.058987 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:128:in `start'
[----] E, [2015-11-17T10:30:25.059094 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/app/models/miq_worker/runner.rb:29:in `start_worker'
[----] E, [2015-11-17T10:30:25.059179 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
[----] E, [2015-11-17T10:30:25.059263 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands/runner.rb:60:in `load'
[----] E, [2015-11-17T10:30:25.059347 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands/runner.rb:60:in `<top (required)>'
[----] E, [2015-11-17T10:30:25.059433 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands/commands_tasks.rb:123:in `require'
[----] E, [2015-11-17T10:30:25.059524 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
[----] E, [2015-11-17T10:30:25.059608 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands/commands_tasks.rb:90:in `runner'
[----] E, [2015-11-17T10:30:25.060154 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
[----] E, [2015-11-17T10:30:25.060244 #5390:f03994] ERROR -- : MIQExtract.extract /opt/rh/cfme-gemset/bundler/gems/rails-8f6ee25ebb3b/railties/lib/rails/commands.rb:17:in `<top (required)>'
[----] E, [2015-11-17T10:30:25.060330 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/bin/rails:4:in `require'
[----] E, [2015-11-17T10:30:25.060413 #5390:f03994] ERROR -- : MIQExtract.extract /var/www/miq/vmdb/bin/rails:4:in `<main>'
[----] I, [2015-11-17T10:30:25.060594 #5390:f03994]  INFO -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::Vm#scan_via_miq_vm) Scanning [vmconfig] information ran for [1.879730202] seconds.  TaskId:[0177666c-8d40-11e5-9ba1-fa163ea62a09]  VM:[test]
[----] E, [2015-11-17T10:30:25.060729 #5390:f03994] ERROR -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::Vm#scan_via_miq_vm) Error: No XML returned for category [vmconfig]  TaskId:[0177666c-8d40-11e5-9ba1-fa163ea62a09]  VM:[test]
Comment 2 Rich Oliveri 2015-11-17 12:57:22 EST

*** This bug has been marked as a duplicate of bug 1279508 ***

Note You need to log in before you can comment on or make changes to this bug.