Bug 1282898 - Update conflict: docker-storage-setup-0.0.4-2.el7.noarch and docker-1.8.2-7.el7.x86_64
Update conflict: docker-storage-setup-0.0.4-2.el7.noarch and docker-1.8.2-7.e...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.1
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 13:40 EST by Chris Evich
Modified: 2015-12-01 01:15 EST (History)
4 users (show)

See Also:
Fixed In Version: docker-1.8.2-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 15:06:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Evich 2015-11-17 13:40:46 EST
Description of problem:
With a RHEL 7.1 GA system, installing the following RPMS causes a conflict:

'docker* atomic procps tar findutils bzip2 gdb bridge-utils nfs-utils git glibc-devel python-bugzilla which cloud-utils-growpart'

with these enabled repos:

'epel rhel-7-server-rpms rhel-7-server-extras-rpms rhel-7-server-optional-rpms rhel-7-server-supplementary-rpms rhel-atomic-host-rpms'

Version-Release number of selected component (if applicable):
docker-1.8.2-7.el7.x86_64

How reproducible:
Reliable

Steps to Reproduce:
1. Beginning with a registered/subscribed RHEL 7.1 GA install, docker RPM installed, disable all repos.
2. Yum install above package list with only above repos enabled.

Actual results:
Transaction check error:
   file /usr/bin/docker-storage-setup conflicts between attempted installs of docker-storage-setup-0.0.4-2.el7.noarch and docker-1.8.2-7.el7.x86_64

Expected results:
Transaction success

Additional info:
As close as I can tell, this began failing on or just before Nov. 12th.
Comment 4 Chris Evich 2015-11-17 13:49:08 EST
Correction: First failure was Nov 16th, not the 12th.
Comment 5 Vivek Goyal 2015-11-17 14:33:18 EST
docker-storage-setup rpm should not be available any longer. Problem seems to be that we are trying to install both docker-storage-setup rpm and docker rpm and they both container file /usr/bin/docker-storage-setup. So now we need to figure out why docker-storage-setup rpm is still available.
Comment 6 Colin Walters 2015-11-17 14:39:48 EST
docker.rpm likely needs Obsoletes: docker-storage-setup

(Atomic Host doesn't have this problem)
Comment 10 Chris Evich 2015-11-18 12:00:18 EST
Isolated the reproducer down to having the rhel-atomic-host-rpms repo enabled and doing a 'yum install 'docker*'.  This is a cross-repo problem that's likely unsupported anyway.  Excluding that repo does not reproduce the problem, and since that package was only in atomic, this can't ever be a supported problem in RHEL (proper).

Note You need to log in before you can comment on or make changes to this bug.