Bug 128291 - KDE doesn't work on IA64 RHEL3u2
Summary: KDE doesn't work on IA64 RHEL3u2
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-21 11:14 UTC by Leigh Upton
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 12:13:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xfree86.0.log (30.33 KB, text/plain)
2004-07-22 08:38 UTC, Leigh Upton
no flags Details

Description Leigh Upton 2004-07-21 11:14:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
A HP zx6000 workstation running RHEL3u2 is unable to run KDE on the
desktop.
With "startkde"; in .xinitrc and in runlevel 3, when X is started from
command line with "startx", the following error messages are shown:

startkde: Starting up...
ksplash: cannot connect to X server :0
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server :0
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.

waiting for X server to shut down

When using "twm"; in the .xinitrc file, X starts up no problems.
However, KDE programs won't start from xterm command line either. They
exit with the same "cannot connect to X server :0" error. Any non-KDE
program starts up fine.
I have tested with both the std kernel and errata kernel
I have tested with the std install and with all the errata
I have tested as a normal user and as root

In all the cases nothing worked.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install with @everything
2. Apply all errata
3. Go into runlevel 3
4. echo "startkde" > ~/.xinitrc; chmod 755 ~/.xinitrc
5. startx
       

Actual Results:  with "startx", the following error messages are shown:

startkde: Starting up...
ksplash: cannot connect to X server :0
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server :0
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.

waiting for X server to shut down

Expected Results:  Should have started kde desktop

Additional info:


Here are some data on the machine:
Model: HP ZX6000 (Dual Itanium-2)
Kernel: 2.4.21-15.0.3.EL
RAM: 8GB
Disks: 2x146GB SCSI-3
Nvidia driver: 5347 (from HP website - for this particular WS model)

Comment 1 Ngo Than 2004-07-21 13:00:01 UTC
does X server run correct on your machine?

could you please try following steps:

- go into runlevel3 (telinit 3)
- remove $HOME/.xinitrc (rm -f  $HOME/.xinitrc)
- start X in simple mode (xinit)

if these steps works, you should get xterm. please try to start KDE in
xterm with "startkde"

does this problem still appear.

could you please send me the /var/log/XFree86.0.log.


does it work if you use GDM to start KDE?




Comment 2 Leigh Upton 2004-07-22 08:38:16 UTC
Created attachment 102133 [details]
Xfree86.0.log

Comment 3 Leigh Upton 2004-07-22 08:40:13 UTC
See above comment (#2) for Xfree86.0.log
Using xinit w/o the .xinitrc and starting kde from within the xterm 
makes no difference.
The same applies to starting KDE from GDM.

Comment 4 Ngo Than 2004-07-22 11:02:44 UTC
I have tried to start KDE applications on ia64 with RHEL3 remotely. It
works fine for me. i cannot reproduce this problem here. 

It seems a setting problem to me here.

Did you start it remotely or locally? are you using HOME over NFS?


Ben, could you reproduce this problem?

Comment 5 Leigh Upton 2004-07-23 05:54:57 UTC
There were no NFS mounts on this machine. I was logging in as root 
when doing most of my testing.
If this is a setting issue then it's a setting issue with the default 
@Everything install, since I didn't modify any system settings. This 
was a cleanly installed machine.



Comment 6 Ngo Than 2004-07-28 16:33:59 UTC
strange! i have done a new RHEL3 installion on ia64. KDE works fine
without this problem. It would be good if i could get a better test case!


Comment 7 Leigh Upton 2004-08-02 09:32:57 UTC
Ngo,

What do you now suggest?

This is delaying the IA64 release for Shell. We have a weekly telecon 
with Larry Troan and Karen Bennett for high profile issues. Should I 
raise this for them to get some more local support made available for 
us.

We need to identify the problem and solution quickly.

Thnaks
Leigh

Comment 8 Ngo Than 2004-08-02 10:34:40 UTC
it looks like you are using nvidia drivers from NVIDIA!

Could you please try to remove nvidia drivers from NVIDIA first and
reconfigure your Xserver for using nv driver from XFree86 and try to
start KDE again?

Please make sure that nvidia drivers from NVIDIA is removed completely.


Comment 9 Leigh Upton 2004-08-03 10:59:46 UTC
Ngo,

I removed the nvidia driver and configured X to use the nv driver. 
KDE now works. This driver is for a certified and supported platform, 
namely the HP ZX6000 workstation. The driver I am using can be found 
here: (may wrap) 
http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?
pnameOID=82069&locale=en_US&taskId=135&prodSeriesId=82067&prodTypeId=1
2454&swEnvOID=1100


Thanks,
Xander


Note You need to log in before you can comment on or make changes to this bug.