This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 128292 - forcedeth broken
forcedeth broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-21 07:49 EDT by Tim Waugh
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.7-1.499
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 08:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch-forcedeth-timer (4.32 KB, patch)
2004-08-27 04:56 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2004-07-21 07:49:27 EDT
Description of problem:
With 2.6.7-1.492 and above the forcedeth network driver does not
detect a link on boot.  2.6.7-1.488 works fine.

Version-Release number of selected component (if applicable):
2.6.7-1.492, 2.6.7-1.494

How reproducible:
100%

Steps to Reproduce:
1. Boot.
  
Actual results:
kernel: eth0: forcedeth.c: subsystem: 01043:80c5 bound to 0000:00:05.0
kernel: eth0: no link during initialization.

(followed by lack of network connectivity)

Expected results:
kernel: eth0: forcedeth.c: subsystem: 01043:80c5 bound to 0000:00:05.0

(followed by working Ethernet)
Comment 1 Tim Waugh 2004-07-29 12:13:49 EDT
Seems fixed.
Comment 2 Tim Waugh 2004-07-30 05:51:19 EDT
No, spoke too soon.  I thought that it worked once with 2.6.7-1.499,
but I certainly can't get it to work now.  I tried booting with
acpi=off but that didn't help.

The version of forcedeth in 2.6.7-1.488 works fine, so I'm sticking to
that for the time being.
Comment 3 Marc Heckmann 2004-08-11 02:43:34 EDT
Just a me too here with the erratta kernel 2.6.7-1.494.2.2. 

Same behaviour with forcedeth on my x86_64 nvidia chipset system.

After the system is booted I have to run dhclient again (or rerun the
init.d/network script) to configure the interface.
Comment 4 Tim Waugh 2004-08-11 05:59:06 EDT
Manfred Spraul sent a patch (against 0.29) to netdev which fixes this.
 Hopefully it will show up in the upstream kernel before too long.
Comment 5 Tim Waugh 2004-08-27 04:56:26 EDT
Created attachment 103158 [details]
patch-forcedeth-timer

Here is Manfred's patch, which works for me.
Comment 6 Tim Waugh 2004-10-14 08:11:34 EDT
This seems to be working fine nowadays.

Note You need to log in before you can comment on or make changes to this bug.