Bug 128296 - OSError: [Errno 12] Não foi possível alocar memória (not possible to allocate memory)
OSError: [Errno 12] Não foi possível alocar memória (not possible to alloc...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 09:23 EDT by Vinícius de Melo Rocha
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 15:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full traceback (659.14 KB, text/plain)
2004-07-21 10:35 EDT, Mike McLean
no flags Details

  None (edit)
Description Vinícius de Melo Rocha 2004-07-21 09:23:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system using fedora CD
2. Proceed with normal installation
3. Choose to partition the system automaticly
4. Wait instalation to starts.    

Actual Results:  The anaconda reports an exception during the 
installation.

Expected Results:  Ask for the second CD, maybe.

Additional info:

Anaconda saved a .txt file on a floppy disk, but it is too big and i 
don't know how to send it attached to this report.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1048, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in 
renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 539, in turnOnFilesystems
    thefsset.formatSwap(instPath)
  File "/usr/lib/anaconda/fsset.py", line 1247, in formatSwap
    self.formatEntry(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1290, in formatEntry
    entry.fsystem.formatDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 709, in formatDevice
    searchPath = 1)
  File "/usr/lib/anaconda/iutil.py", line 55, in execWithRedirect
    childpid = os.fork()
OSError: [Errno 12] Não foi possível alocar memória

Local variables in innermost frame:
searchPath: 1
stdout: /dev/tty5
stdin: 0
argv: ['mkswap', '-v1', '/tmp/hda5']
ignoreTermSigs: 0
command: /usr/sbin/mkswap
stderr: /dev/tty5
newPgrp: 0
root: /
Comment 1 Mike McLean 2004-07-21 10:35:32 EDT
Created attachment 102106 [details]
full traceback

The reported mailed me this traceback.
Comment 2 Jeremy Katz 2004-07-26 23:35:21 EDT
How much memory is in the machine?
Comment 3 Vinícius de Melo Rocha 2004-07-27 06:40:28 EDT
The problem was that the swap was not formated, so it bugged when it
ask for the second instalation disk. The problem now is that the GRUB
does not work.

By the way, the computer have 128M of RAM memory.

Note You need to log in before you can comment on or make changes to this bug.