Bug 128298 - 32 bit applications cannot run on ia64
32 bit applications cannot run on ia64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 10:30 EDT by Leigh Upton
Modified: 2014-03-16 22:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 23:30:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leigh Upton 2004-07-21 10:30:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
On RHEL 2.1, 32 bit applications were supported out of the box.

This does not seem to be the same for RHEL 3.0. There are no
instructions available on how to achieve this. 

Can you please advise.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install e.g. acrobat
2. Fails to run.
3.
    

Expected Results:  Works on RHEL 2.1

Additional info:
Comment 1 Bill Nottingham 2004-07-21 11:24:14 EDT
What specific problems are you seeing?
Comment 2 Leigh Upton 2004-07-23 01:59:49 EDT
As stated in the bug report:
No 32bit apps can be run (no libs available)
No instructions on how to achieve this can be found.
When I tried to install the rpms from the compat libs iso which we 
were given (See issue tracker #Issue 44130), I get file conflicts 
which I am reluctant to force or use --replacefiles on.
On RHEL2.1 there was package that was called x86-compat or something 
along those lines and it had all these libs that we needed to run 
these apps.
How do I achieve the same level of compatibility on the RHEL3 
platform?
Comment 3 Bill Nottingham 2004-07-23 12:06:49 EDT
Jay: have you seen conflict issues with the compat libs isos?
Comment 4 Leigh Upton 2004-08-03 07:07:26 EDT
I would like to know if someone is looking into this. We still have 
no solution to get the 32bit compat libs installed w/o problems.

Thanks,
Xander
Comment 5 Jay Turner 2004-08-09 12:23:38 EDT
All of the 32-bit compat packages are included in the RHEL3-U3 beta
code which is currently available.  Are you still seeing conflicts
with that code?  Also, what architecture are you installing on?  The
bug indicates IA64, but I thought you folks were putting the EM64T
stuff through its paces?
Comment 6 Larry Troan 2004-08-10 21:25:40 EDT
From Issue Tracker....
------ Event posted 08-10-2004 02:45am by xander.soldaat 	
We received links to both the ia64 and em64t compat lib isos, so we
tried both on their respective platforms. We have 32bit compat working
now on the em64t, but not on the ia64. The conflicts tend to be mainly
for files residing in /usr/share and /etc, I have no specific examples
right now.

Thanks,
Xander
Comment 8 Bill Nottingham 2005-01-18 14:03:31 EST
Putting in needinfo; need specific examples of conflicts.

Note You need to log in before you can comment on or make changes to this bug.