Bug 128303 - Can't "click to raise" anywhere in window
Summary: Can't "click to raise" anywhere in window
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: metacity (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-21 15:49 UTC by Joshua Jensen
Modified: 2007-11-30 22:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 06:17:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2004-07-21 15:49:18 UTC
Description of problem:

The older and new functionality in GNOME isn't persent in RHEL3. 
Where is "click to raise"... where I can click anywhere in the window
that I want to raise?


Version-Release number of selected component (if applicable):

RHEL3 with all updates

For a possible patch see:
http://mail.gnome.org/archives/desktop-devel-list/2003-June/msg00482.html
https://listman.redhat.com/archives/fedora-desktop-list/2004-April/msg00013.html

Comment 1 Havoc Pennington 2004-08-09 03:09:39 UTC
U3 or possibly an errata in the post-U3 queue has a hack for this.


Comment 2 Joshua Jensen 2004-09-24 17:04:33 UTC
Havoc... is this now scheduled for U4?

Comment 3 Dario Landazuri 2004-10-14 16:39:01 UTC
Is there any word on if/when this will be fixed?   It would be nice
for me and a bunch of my users who've asked me about this behavior change.

Thanks,
Dario

Comment 4 Havoc Pennington 2004-10-14 17:39:29 UTC
There's a setting /apps/metacity/rhel3_extensions/raise_on_click 
in Update 4.


Comment 5 Dario Landazuri 2004-11-01 16:30:04 UTC
Hm.  I went and grabbed the U4 beta version of metacity and installed
it.  The option was there, but it didn't seem to work.  The update
didn't seem to want any additional dependancies.  Did I miss something
related I was supposed to have updated as well?

Comment 6 Bastien Nocera 2004-12-06 15:48:03 UTC
/apps/metacity/rhel3_extensions/raise_on_click doesn't have any
effects when using Focus Follows Mouse.

Comment 7 Havoc Pennington 2004-12-06 19:35:14 UTC
Oh, I see - this bug is the reverse problem, i.e. wanting to raise
when it doesn't. raise_on_click was added so you could disable raise
when it did.

Comment 14 Lee Whatley 2004-12-28 21:41:36 UTC
What's the status on this?  I have the metacity packages from update4
installed, but I still can't raise windows unless I click on the
window decorations.  What values are the raise_on_click and
strict_pointer_mode supposed to have in order to be able to get the
behavior I am looking for?

Also, I was initinally unable to see /apps/metacity/rhel3_workarounds
in gconf-editor because the file
/etc/gconf/gconf.xml.defaults/apps/metacity/rhel3_workarounds was set
to 750 instead of 755.  This is because up2date used my default umask
(037) instead of getting the file permissions from the rpm file
itself.  This is similar to bug#143486
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143486)

Comment 15 Lee Whatley 2004-12-28 22:00:43 UTC
Sorry, I guess I posted too soon.  In gconf-editor if I right-click on
both raise_on_click and strict_pointer_mode and select "unset" I am
able to get the window focus behavior that I was looking for.  The
issue with
/etc/gconf/gconf.xml.defaults/apps/metacity/rhel3_workarounds getting
installed with my default umask of 037 should probably still be
considered a bug however.


Comment 16 Joshua Jensen 2005-01-28 15:53:33 UTC
Come on Red Hat, we your faithful customers believe in you... and have
for the past six months of this bug being open.  Please dedicate the
resources this problem needs.  Let's close it and be done with it!

Comment 17 Havoc Pennington 2005-01-28 18:09:46 UTC
It's already closed...


Comment 18 Joshua Jensen 2005-01-28 18:21:30 UTC
It is?  I see above:

Status:  MODIFIED


I'm confused

Comment 19 Havoc Pennington 2005-01-29 13:41:53 UTC
MODIFIED = supposed to be fixed
QA gets to some number of MODIFIED and changes them to FIXED

Comment 20 Joshua Jensen 2005-06-06 16:17:19 UTC
Ok... so how is the QA going for this bug?

Comment 22 Havoc Pennington 2005-06-07 23:36:55 UTC
QA doesn't move all MODIFIED bugs to FIXED, only certain bugs.

It's supposed to be fixed. If it isn't, then let us know the version and the
observed vs. expected behavior, and values of
gconftool-2 --get /apps/metacity/rhel3_workarounds/raise_on_click and 
gconftool-2 --get /apps/metacity/rhel3_workarounds/strict_pointer_mode


Comment 23 Joshua Jensen 2005-06-08 13:56:41 UTC
What errata was this fixed in?  What version should I be checking?

Comment 24 Havoc Pennington 2005-06-09 20:05:46 UTC
The latest for RHEL3, afaik. RHEL4 should also work.



Note You need to log in before you can comment on or make changes to this bug.