Bug 1283092 - [RFE] Virtio 1 support for dpdk-vhost-port
[RFE] Virtio 1 support for dpdk-vhost-port
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dpdk (Show other bugs)
7.3
Unspecified Unspecified
high Severity unspecified
: rc
: 7.4
Assigned To: Marcel Apfelbaum
Pei Zhang
: Extras, FutureFeature
: 1227349 (view as bug list)
Depends On:
Blocks: 1283104 1288337 1395265
  Show dependency treegraph
 
Reported: 2015-11-18 04:22 EST by Amnon Ilan
Modified: 2017-01-12 06:24 EST (History)
7 users (show)

See Also:
Fixed In Version: DPDK v2.2.0
Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 06:24:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amnon Ilan 2015-11-18 04:22:44 EST
Description of problem:

In the DPDK vhost-port (the counter part of vhost-user), add support 
for virtio-1


How reproducible:

Bring the Qemu guest up with disable-legacy=on, disable-modern=off and check for proper operation
Comment 2 Amnon Ilan 2015-11-18 04:42:10 EST
This is a requirement for efficient use of VFIO with Virtio devices, since it allows memory mapped operation removing the need for system calls.
Virtio-0 uses only port-IO (no memory IO).
Comment 3 Marcel Apfelbaum 2015-11-25 10:43:21 EST
Upstream commits:
 - commit 15e9ee6982a4822ce395fd597dd500a61ceafa7c (vhost: enable virtio 1.0)
 - commit 45c55d39c5ebb8f8e1e70401dd0492f6c935455b (vhost: fix build with old kernels)

Thanks,
Marcel
Comment 6 Amnon Ilan 2016-01-23 14:46:08 EST
*** Bug 1227349 has been marked as a duplicate of this bug. ***
Comment 7 Mike McCune 2016-03-28 19:00:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Marcel Apfelbaum 2017-01-12 06:24:31 EST
The support is there for a long time, we don't need this BZ anymore.

Note You need to log in before you can comment on or make changes to this bug.