Bug 1283128 - kdump interferes with parted
kdump interferes with parted
Status: CLOSED DUPLICATE of bug 1283112
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: kdump team
Kernel General QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 05:44 EST by Stef Walter
Modified: 2015-11-18 07:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 07:40:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2015-11-18 05:44:04 EST
Description of problem:

Right after boot, kdump.service is busy for some time and during
that time parted fails when creating a new partition.

Workaround: systemctl disable kdump.service
Comment 1 Stef Walter 2015-11-18 05:44:40 EST
Marius, could you provide further information here, including:

 * Version-Release number of selected component (if applicable):
 * How reproducible:
 * Steps to Reproduce:
 * Actual results:
 * Expected results:
Comment 3 Minfei Huang 2015-11-18 05:52:08 EST
(In reply to Stef Walter from comment #0)
> Description of problem:
> 
> Right after boot, kdump.service is busy for some time and during
> that time parted fails when creating a new partition.

Does parted device is used by kdump service? Do you use the default kdump config (locates in /etc/kdump.conf) or modify the config? If so, could you mind pasting the config.

Thanks
Minfei

> 
> Workaround: systemctl disable kdump.service
Comment 4 Marius Vollmer 2015-11-18 07:40:30 EST
This should be covered by bug 1283112.

kdump only interferes with parted in so far as it puts load on the system, which causes the race between parted and udevd to have a different winner.  I have reproduced bug 1283112 with a simple "while true; do true; done" loop to produce the load.

(I should have updated the comment in cockpit-rhel-7.setup after I figured this out.  Sorry about that.)

*** This bug has been marked as a duplicate of bug 1283112 ***

Note You need to log in before you can comment on or make changes to this bug.