Bug 128315 - when using smp kernel with one cpu server linux use two cpu
Summary: when using smp kernel with one cpu server linux use two cpu
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-21 18:09 UTC by giovanni stinco
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 23:43:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giovanni stinco 2004-07-21 18:09:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
for some times we keep running a linux box using an smp kernel
(kernel-smp-2.4.21-15.0.3.EL.i686.rpm)but the server has just one cpu.
when using top or seeing in /proc/cpuinfo we saw two cpu.
our server has an intel xeon cpu with Hyper-Threading technology.
now we have boot with a non-smp kernel and we see just one cpu (correct)
this is always reproducible using a xeon cpu with Hyper-Threading
technology and the last smp kernel release.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-15.0.3.EL.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1.boot with a smp-kernel on a single cpu server
2.type "top" display two cpu
3.type "cat /proc/cpuinfo" display two cpu
    

Actual Results:  point 2 and 3 always display two cpu

Expected Results:  the o.s. must show just one cpu

Additional info:

i think this note is a bit obscure (and we cannot reproduce it anymore
because our server are now in prodution enviroment) but... we are
running an apache (2.0.50) web server compiled with mpm worker. with
the situation described below (smp kernel and one xeon cpu) with have
always problem with the treadh (after some time -random time but is
always a matter of hours, sometimes minutes- some thread began to use
all the cpu resources. in detail: the first "hang" thread use 50% and
when the second hang all the cpu was used (50% for the first one and
50% for the second one). N.B.:one thread never use all the cpu
resources. after some time others threads began to hang and the cpu
resorces are divided equaly over all the hang threads.

we had boot whith a non-smp kernel (the last one released for rh ES
3.0) and the apache works well.

some notes: apache is the original one taken from the www.apache.org
web-sited, non the redhat one so we understand about the non-support
policy... but i think the description below can be maybe useful.

Comment 1 Ernie Petrides 2004-07-22 23:43:25 UTC
Hello, Giovanni.  When a physical CPU that is capable of
hyperthreading is used by an SMP kernel, there are indeed
two virtual CPUs, each of which can execute a separate
process at the same time.  The behavior you have described
is expected (and desired).



Note You need to log in before you can comment on or make changes to this bug.