Bug 1283184 - FTBFS in string/test-memcmp.c
FTBFS in string/test-memcmp.c
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
s390 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Weimer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2015-11-18 07:20 EST by Dan Horák
Modified: 2015-12-07 03:10 EST (History)
8 users (show)

See Also:
Fixed In Version: glibc-2.22.90-19.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 03:10:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2015-11-18 07:20:03 EST
from build.log
...
gcc test-wmemcmp.c -c -std=gnu11 -fgnu89-inline  -O3 -Wall -Werror -Wundef -Wwrite-strings -fasynchronous-unwind-tables -fmerge-all-constants -fno-asynchronous-unwind-tables -frounding-math -g -Wstrict-prototypes -Wold-style-definition -mlong-double-128          -I../include -I/builddir/build/BUILD/glibc-2.22-491-gaf1b2fd/build-s390-redhat-linux/wcsmbs  -I/builddir/build/BUILD/glibc-2.22-491-gaf1b2fd/build-s390-redhat-linux  -I../sysdeps/unix/sysv/linux/s390/s390-32  -I../sysdeps/unix/sysv/linux/s390/fpu  -I../sysdeps/s390/fpu  -I../sysdeps/unix/sysv/linux/s390  -I../sysdeps/s390/nptl  -I../sysdeps/ieee754/ldbl-64-128  -I../sysdeps/ieee754/ldbl-opt  -I../sysdeps/unix/sysv/linux/include -I../sysdeps/unix/sysv/linux  -I../sysdeps/nptl  -I../sysdeps/pthread  -I../sysdeps/gnu  -I../sysdeps/unix/inet  -I../sysdeps/unix/sysv  -I../sysdeps/unix  -I../sysdeps/posix  -I../sysdeps/s390/s390-32/multiarch  -I../sysdeps/s390/s390-32  -I../sysdeps/wordsize-32  -I../sysdeps/s390/multiarch  -I../sysdeps/s390  -I../sysdeps/ieee754/ldbl-128  -I../sysdeps/ieee754/dbl-64  -I../sysdeps/ieee754/flt-32  -I../sysdeps/ieee754  -I../sysdeps/generic  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/s390-redhat-linux/5.1.1/include -isystem /usr/include  -D_LIBC_REENTRANT -include /builddir/build/BUILD/glibc-2.22-491-gaf1b2fd/build-s390-redhat-linux/libc-modules.h -DMODULE_NAME=nonlib -include ../include/libc-symbols.h       -D_IO_MTSAFE_IO -o /builddir/build/BUILD/glibc-2.22-491-gaf1b2fd/build-s390-redhat-linux/wcsmbs/test-wmemcmp.o -MD -MP -MF /builddir/build/BUILD/glibc-2.22-491-gaf1b2fd/build-s390-redhat-linux/wcsmbs/test-wmemcmp.o.dt -MT /builddir/build/BUILD/glibc-2.22-491-gaf1b2fd/build-s390-redhat-linux/wcsmbs/test-wmemcmp.o
In file included from ../string/test-memcmp.c:27:0,
                 from test-wmemcmp.c:2:
../string/test-memcmp.c: In function 'check1':
../string/test-string.h:135:19: error: array subscript is above array bounds [-Werror=array-bounds]
      if (func_list[f].usable)     \
                   ^
../string/test-memcmp.c:446:7: note: in expansion of macro 'FOR_EACH_IMPL'
       FOR_EACH_IMPL (impl, 0)
       ^
../string/test-string.h:137:22: error: array subscript is above array bounds [-Werror=array-bounds]
   a->name = func_list[f].name;    \
                      ^
../string/test-memcmp.c:446:7: note: in expansion of macro 'FOR_EACH_IMPL'
       FOR_EACH_IMPL (impl, 0)
       ^
../string/test-string.h:138:20: error: array subscript is above array bounds [-Werror=array-bounds]
   a->fn = func_list[f].fn;    \
                    ^
../string/test-memcmp.c:446:7: note: in expansion of macro 'FOR_EACH_IMPL'
       FOR_EACH_IMPL (impl, 0)
       ^



Version-Release number of selected component (if applicable):
glibc-2.22.90-13.fc24 (but exists since glibc-2.22.90-6.fc24 at least)


Additional info:
Comment 1 Dan Horák 2015-11-18 07:21:05 EST
It's on 32-bit s390 with gcc-5.1.1-4.fc23.s390
Comment 2 Florian Weimer 2015-11-18 07:27:04 EST
Possible cause: https://sourceware.org/bugzilla/show_bug.cgi?id=19261

I will work around this by disabling -Werror for s390 in rawhide, until we have an upstream fix.

Note You need to log in before you can comment on or make changes to this bug.