Bug 1283187 - [GlusterD]: Incorrect peer status showing if volume restart done before entire cluster update.
[GlusterD]: Incorrect peer status showing if volume restart done before enti...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
glusterd
: ZStream
Depends On: 1283035 1283178
Blocks: 1248895
  Show dependency treegraph
 
Reported: 2015-11-18 07:24 EST by Vijaikumar Mallikarjuna
Modified: 2016-04-19 03:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283178
Environment:
Last Closed: 2016-04-19 03:48:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-18 07:25:13 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of quota version) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-11-18 07:35:40 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of quota version) posted (#2) for review on release-3.7 by Anand Nekkunti (anekkunt@redhat.com)
Comment 3 Vijay Bellur 2015-11-19 01:04:32 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of quota version) posted (#3) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2015-11-19 05:12:40 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of new quota volinfo option) posted (#4) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2015-12-04 02:14:26 EST
REVIEW: http://review.gluster.org/12879 (quota: add 'quota-version' to xlator volume_options structure) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Vijay Bellur 2015-12-09 00:29:32 EST
COMMIT: http://review.gluster.org/12879 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit df38146d698b5acbf51d983766322cc0cb10b47b
Author: vmallika <vmallika@redhat.com>
Date:   Fri Dec 4 12:36:22 2015 +0530

    quota: add 'quota-version' to xlator volume_options structure
    
    This is a backport of http://review.gluster.org/#/c/12878/
    
    Below error is seen in brick log:
    0-vol1-quota: option 'quota-version' is not recognized
    
    So add this option to the volume_options structure of
    marker xlator
    
    > Change-Id: I1bd68a537936ee0f9af85dac74f1377f84edb8f4
    > BUG: 1283178
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I108cfa2cb829daad9aca80cbd630b9afab0b05a7
    BUG: 1283187
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12879
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 7 Vijay Bellur 2015-12-09 02:46:18 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of new quota volinfo option) posted (#5) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 8 Vijay Bellur 2015-12-09 12:07:50 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of new quota volinfo option) posted (#6) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 9 Vijay Bellur 2015-12-17 03:14:30 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of new quota volinfo option) posted (#7) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 10 Vijay Bellur 2015-12-21 04:00:48 EST
REVIEW: http://review.gluster.org/12643 (quota: fix backward compatibility of new quota volinfo option) posted (#8) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 11 Vijay Bellur 2015-12-22 04:30:28 EST
COMMIT: http://review.gluster.org/12643 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 72176d439780afdb8b67de86182dd7444f1fb7d5
Author: vmallika <vmallika@redhat.com>
Date:   Wed Dec 9 13:13:17 2015 +0530

    quota: fix backward compatibility of new quota volinfo option
    
    This is a backport of http://review.gluster.org/#/c/12642/
    
    quota-version features is implemented for 3.7.6
    please see below patch for more details:
    http://review.gluster.org/#/c/12386
    
    As part of this feature, new volume info option 'quota-version'
    was introduced, this can cause check-sum problem
    when a one of the node in a cluster is upgraded to 3.7.6
    (heterogeneous cluster)
    
    So do a OP_VERSION check when storing this option
    in volume info
    
    > Change-Id: Ic5b03a1e3f1236b645a065b1fadee7950307e191
    > BUG: 1283178
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I878202dcf5b44dcbbeff0d5b798649363a96e422
    BUG: 1283187
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12643
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 12 Kaushal 2016-04-19 03:48:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.