Bug 1283205 - MIQ(MiqServer#validate_worker) Worker [ManageIQ::Providers::Vmware::InfraManager::EventCatcher]found in evm.log file
MIQ(MiqServer#validate_worker) Worker [ManageIQ::Providers::Vmware::InfraMana...
Status: CLOSED DUPLICATE of bug 1281746
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity low
: GA
: 5.5.0
Assigned To: Gregg Tanzillo
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 07:55 EST by Ramesh A
Modified: 2015-11-18 11:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 11:20:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2015-11-18 07:55:02 EST
Description of problem:
"MIQ(MiqServer#validate_worker) Worker [ManageIQ::Providers::Vmware::InfraManager::EventCatcher] with ID: [1437], PID: [13502], GUID: [f3913684-8deb-11e5-94fb-fa163ea62a09] has not responded in 131.319350718 seconds, restarting worker" found in evm.log file

Version-Release number of selected component (if applicable):
5.5.0.10-beta2.1.20151110134042_d6f5459

How reproducible:
Very

Steps to Reproduce:
1. Deploy new appliance and manage Vsphere55 provider
2. Wait for sometime and check the evm.log file


Actual results:
After sometime, MIQ(MiqServer#validate_worker) error is found in the evm.log file.  Refer the evm.log for more details


Expected results:
Should not throw any error message.

Additional info:
evm.log:
========
[----] I, [2015-11-18T07:52:15.472318 #3060:11b5994]  INFO -- : MIQ(MiqGenericWorker::Runner#get_message_via_drb) Message id: [399], MiqWorker id: [13], Zone: [default], Role: [], Server: [], Ident: [generic]
, Target id: [], Instance id: [259], Task id: [], Command: [ManageIQ::Providers::Vmware::InfraManager::Vm.post_create_actions], Timeout: [600], Priority: [100], State: [dequeue], Deliver On: [], Data: [], Arg
s: [], Dequeued in: [40.242847211] seconds
[----] I, [2015-11-18T07:52:15.472494 #3060:11b5994]  INFO -- : MIQ(MiqQueue#deliver) Message id: [399], Delivering...
[----] I, [2015-11-18T07:52:15.491486 #3057:11ff990]  INFO -- : <AutomationEngine> MiqAeEvent.build_evm_event >> event=<"vm_template"> inputs=<{:vm=>#<ManageIQ::Providers::Vmware::InfraManager::Template id: 2
60, vendor: "vmware", format: nil, version: nil, name: "s_tpl_upstream_151105_tQ5vQj9d", description: nil, location: "s_tpl_upstream_151105_tQ5vQj9d/s_tpl_upstream_1511...", config_xml: nil, autostart: nil, h
ost_id: 3, last_sync_on: nil, created_on: "2015-11-18 12:51:14", updated_on: "2015-11-18 12:51:14", storage_id: 11, guid: "0d5734e0-8df3-11e5-8b57-001a4a60db02", ems_id: 1, last_scan_on: nil, last_scan_attemp
t_on: nil, uid_ems: "4216f897-fee0-85c0-e336-a889866f8126", retires_on: nil, retired: nil, boot_time: "2015-11-06 00:34:44", tools_status: "toolsNotRunning", standby_action: "checkpoint", power_state: "never"
, state_changed_on: "2015-11-18 12:51:14", previous_state: nil, connection_state: "connected", last_perf_capture_on: nil, registered: nil, busy: nil, smart: nil, memory_reserve: 0, memory_reserve_expand: fals
e, memory_limit: -1, memory_shares: 61440, memory_shares_level: "normal", cpu_reserve: 0, cpu_reserve_expand: false, cpu_limit: -1, cpu_shares: 4000, cpu_shares_level: "normal", cpu_affinity: nil, ems_created
_on: nil, template: true, evm_owner_id: nil, ems_ref_obj: "--- !ruby/string:VimString\nstr: vm-117634\nxsiType:...", miq_group_id: 1, linked_clone: true, fault_tolerance: false, type: "ManageIQ::Providers::Vm
ware::InfraManager::Templat...", ems_ref: "vm-117634", ems_cluster_id: 1, retirement_warn: nil, retirement_last_warn: nil, vnc_port: nil, flavor_id: nil, availability_zone_id: nil, cloud: false, retirement_st
ate: nil, cloud_network_id: nil, cloud_subnet_id: nil, cloud_tenant_id: nil, raw_power_state: "never", publicly_available: nil, orchestration_stack_id: nil, retirement_requester: nil, tenant_id: 1, resource_g
roup_id: nil>, :host=>#<ManageIQ::Providers::Vmware::InfraManager::HostEsx id: 3, name: "cfme-esx-55-01.cfme.lab.eng.rdu2.redhat.com", hostname: "cfme-esx-55-01.cfme.lab.eng.rdu2.redhat.com", ipaddress: "10.8
.58.12", vmm_vendor: "vmware", vmm_version: "5.5.0", vmm_product: "ESXi", vmm_buildnumber: "1331820", created_on: "2015-11-18 12:50:23", updated_on: "2015-11-18 12:50:23", guid: "eec6f218-8df2-11e5-8b57-001a4
a60db02", ems_id: 1, user_assigned_os: nil, power_state: "on", smart: 1, settings: nil, last_perf_capture_on: nil, uid_ems: "cfme-esx-55-01", connection_state: "connected", ssh_permit_root_login: nil, ems_ref
_obj: "--- !ruby/string:VimString\nstr: host-244\nxsiType: ...", admin_disabled: false, service_tag: "KQ7BK95", asset_tag: "none", ipmi_address: nil, mac_address: nil, type: "ManageIQ::Providers::Vmware::Infr
aManager::HostEsx", failover: nil, ems_ref: "host-244", hyperthreading: true, ems_cluster_id: 1, next_available_vnc_port: nil, hypervisor_hostname: nil, availability_zone_id: nil>, "MiqEvent::miq_event"=>260,
 :miq_event_id=>260, "EventStream::event_stream"=>260, :event_stream_id=>260}>
[----] E, [2015-11-18T07:52:15.501524 #2863:c3198c] ERROR -- : MIQ(MiqServer#validate_worker) Worker [ManageIQ::Providers::Vmware::InfraManager::EventCatcher] with ID: [23], PID: [4076], GUID: [db1a3720-8df2-11e5-bf0a-001a4a60db02] has not responded in 131.707617255 seconds, restarting worker
Comment 2 Ramesh A 2015-11-18 08:36:03 EST
Same error is found even for other providers too.  Added RHOS7 provider and found the same kind of error message.

[----] E, [2015-11-18T08:32:56.315761 #14043:123598c] ERROR -- : MIQ(MiqServer#validate_worker) Worker [ManageIQ::Providers::Openstack::CloudManager::EventCatcher] with ID: [1475], PID: [32533], GUID: [8fdc26dc-8df8-11e5-94fb-fa163ea62a09] has not responded in 122.367130305 seconds, restarting worker


This error message keeps on repeating on the evm.log file
Comment 3 Joe Vlcek 2015-11-18 11:20:23 EST

*** This bug has been marked as a duplicate of bug 1281746 ***

Note You need to log in before you can comment on or make changes to this bug.