Bug 1283211 - check_host_list() should be more robust
check_host_list() should be more robust
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
mainline
All All
medium Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1278900
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 08:05 EST by Cedric Buissart
Modified: 2016-06-16 09:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278900
Environment:
Last Closed: 2016-06-16 09:45:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2044613 None None None Never

  None (edit)
Comment 1 Vijay Bellur 2015-11-18 08:47:43 EST
REVIEW: http://review.gluster.org/12588 (glusterd-ganesha xlator parser for ganesha-ha.conf) posted (#2) for review on master by Cedric Buissart (cedric.buissart@gmail.com)
Comment 2 Vijay Bellur 2015-11-18 09:18:31 EST
REVIEW: http://review.gluster.org/12588 (glusterd-ganesha xlator parser for ganesha-ha.conf) posted (#4) for review on master by Cedric Buissart (cedric.buissart@gmail.com)
Comment 3 Vijay Bellur 2015-11-18 09:22:29 EST
REVIEW: http://review.gluster.org/12588 (glusterd-ganesha xlator parser for ganesha-ha.conf) posted (#5) for review on master by Cedric Buissart (cedric.buissart@gmail.com)
Comment 4 Vijay Bellur 2015-11-20 10:53:21 EST
REVIEW: http://review.gluster.org/12588 (glusterd-ganesha xlator parser for ganesha-ha.conf) posted (#6) for review on master by Cedric Buissart (cedric.buissart@gmail.com)
Comment 5 Vijay Bellur 2015-11-25 11:27:40 EST
REVIEW: http://review.gluster.org/12588 (glusterd-ganesha xlator parser for ganesha-ha.conf) posted (#7) for review on master by Cedric Buissart (cedric.buissart@gmail.com)
Comment 6 Vijay Bellur 2015-12-01 14:24:38 EST
COMMIT: http://review.gluster.org/12588 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit de9c322dfbe5c4f9da65fbe0eef443440eafbbdc
Author: Cedric Buissart <cbuissar@redhat.com>
Date:   Mon Nov 16 15:32:29 2015 +0100

    glusterd-ganesha xlator parser for ganesha-ha.conf
    
    The current method for parsing ganesha-ha.conf is prone to issues :
    Before the patch :
    - no double quote leads to segfault
       e.g. : HA_CLUSTER_NODES=server1,server2
    - no check for comments.
       e.g. : #HA_CLUSTER_NODES="server1,server2"
          would be used if preceding the real value
    
    This is an attempt to a cleaner parser:
    1- factorization of parsing code, creating 1 dedicated, more generic
    parser
    2- double quote are no longer mandatory
    3- should not segfault
    4- lines are no longer limited to 1024 chars
    
    Resolves RHBZ 1283211
    
    Change-Id: I75f11461fe1b84915d1c5cfe945b47bd81abc2b1
    BUG: 1283211
    Signed-off-by: Cedric Buissart <cbuissar@redhat.com>
    Reviewed-on: http://review.gluster.org/12588
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 7 Mike McCune 2016-03-28 18:53:35 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Niels de Vos 2016-06-16 09:45:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.