Bug 1283272 - Move nuxwdog perl bindings to a sub package
Move nuxwdog perl bindings to a sub package
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nuxwdog (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ade Lee
Asha Akkiangady
:
Depends On: 1245151
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 10:07 EST by Nathan Kinder
Modified: 2016-11-04 03:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1245151
Environment:
Last Closed: 2016-11-04 03:35:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2015-11-18 10:07:59 EST
+++ This bug was initially created as a clone of Bug #1245151 +++

Move the perl bindings to a sub package. This is a standard packaging process as it keeps things as modular/granular as possible. It seems there use to be one long before any git history.

nuxwdog is useful without having to have perl installed (ie using the java client) so it would be nice not having to pull in 26Mb of perl deps.

Spec file patch attached. The rpm auto deps/provides for any packages that depend on the perl bindings with just pull the sub package in using yum/dnf so upgrades should be seemless.

Scatch build (f23): http://koji.fedoraproject.org/koji/taskinfo?taskID=10424846

Deps with the perl:

$ dnf install nuxwdog
Last metadata expiration check performed 1:00:55 ago on Tue Jul 21 05:14:41 2015.
Dependencies resolved.
====================================================================================
 Package                           Arch            Version             Repository Size
====================================================================================
Installing:
 nuxwdog                           armv7hl         1.0.3-3.fc23        fedora   54 k
 perl                              armv7hl         4:5.22.0-349.fc23   fedora  7.0 M
 perl-Carp                         noarch          1.36-346.fc23       fedora   28 k
 perl-Encode                       armv7hl         3:2.75-1.fc23       fedora  1.0 M
 perl-Exporter                     noarch          5.72-347.fc23       fedora   33 k
 perl-File-Path                    noarch          2.09-347.fc23       fedora   31 k
 perl-File-Temp                    noarch          0.23.04-346.fc23    fedora   61 k
 perl-Getopt-Long                  noarch          2.47-1.fc23         fedora   61 k
 perl-HTTP-Tiny                    noarch          0.056-3.fc23        fedora   53 k
 perl-MIME-Base64                  armv7hl         3.15-348.fc23       fedora   29 k
 perl-PathTools                    armv7hl         3.56-346.fc23       fedora   85 k
 perl-Pod-Escapes                  noarch          1:1.07-348.fc23     fedora   19 k
 perl-Pod-Perldoc                  noarch          3.25-347.fc23       fedora   84 k
 perl-Pod-Simple                   noarch          1:3.30-3.fc23       fedora  211 k
 perl-Pod-Usage                    noarch          4:1.67-3.fc23       fedora   33 k
 perl-Scalar-List-Utils            armv7hl         2:1.42-3.fc23       fedora   59 k
 perl-Socket                       armv7hl         3:2.020-1.fc23      fedora   54 k
 perl-Storable                     armv7hl         1:2.53-346.fc23     fedora   77 k
 perl-Term-ANSIColor               noarch          4.03-346.fc23       fedora   45 k
 perl-Term-Cap                     noarch          1.16-1.fc23         fedora   20 k
 perl-Text-ParseWords              noarch          3.30-346.fc23       fedora   17 k
 perl-Text-Tabs+Wrap               noarch          2013.0523-346.fc23  fedora   23 k
 perl-Time-HiRes                   armv7hl         1.9726-346.fc23     fedora   50 k
 perl-Time-Local                   noarch          1.2300-346.fc23     fedora   29 k
 perl-Unicode-Normalize            noarch          1.19-1.fc23         fedora   26 k
 perl-constant                     noarch          1.33-347.fc23       fedora   24 k
 perl-libs                         armv7hl         4:5.22.0-349.fc23   fedora  710 k
 perl-macros                       armv7hl         4:5.22.0-349.fc23   fedora   57 k
 perl-parent                       noarch          1:0.234-3.fc23      fedora   18 k
 perl-podlators                    noarch          2.5.3-347.fc23      fedora  112 k
 perl-threads                      armv7hl         1:2.02-2.fc23       fedora   56 k
 perl-threads-shared               armv7hl         1.48-346.fc23       fedora   42 k

Transaction Summary
====================================================================================
Install  32 Packages

Total download size: 10 M
Installed size: 26 M
Is this ok [y/N]: n
Operation aborted.
Comment 1 Ade Lee 2016-06-24 14:26:47 EDT
remote: *** Checking commit 8e2f01f2acffeecdf6ee5e744c48a1056c27e49d
remote: *** Resolves:
remote: ***   Approved:
remote: ***     rhbz#1283272 (rhel-7.3.0+, pm_ack+)
remote: *** Commit 8e2f01f2acffeecdf6ee5e744c48a1056c27e49d allowed
To ssh://alee@pkgs.devel.redhat.com/rpms/nuxwdog
   2414329..8e2f01f  rhel-7.3 -> rhel-7.3
Comment 3 Roshni 2016-07-29 13:44:23 EDT
Since perl packages were already installed on a RHEL 7.3 beaker machine, performed sanity test as explained in https://bugzilla.redhat.com/show_bug.cgi?id=1214859#c5 to verify this bug.
Comment 5 errata-xmlrpc 2016-11-04 03:35:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2488.html

Note You need to log in before you can comment on or make changes to this bug.