Bug 128328 - C/C++ Projects view doesn't handle changes in .* files
C/C++ Projects view doesn't handle changes in .* files
Status: CLOSED UPSTREAM
Product: Red Hat Developer Suite
Classification: Retired
Component: CDT (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 15:29 EDT by Aaron Luchko
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 11:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Luchko 2004-07-21 15:29:38 EDT
Description of problem: 
In the C/C++ Projects view try adding/deleting/renaming a .* file in a
C/C++ project, the view will not record any change, ie if you add .foo
it won't show up, if you delete .foo it will still show up, if you
move .foo to .bar .foo will still be the displayed name for the file.
 The changes are made correctly in the file system.  I've encountered
similar behavior with files without .* names but with less certainty,
it seems to happen only once you've tried moving around .* files. 
However if you attempt the same actions on a Java Project in the C/C++
Projects view they will works as intended.


Version-Release number of selected component (if applicable): 
eclipse-cdt-2.0-4

How reproducible:
Always


Steps to Reproduce:
1. Create new C project, Standard Make Project and switch to C/C++
perspective as prompted and "C/C++ Projects" view
2. Create new File, ".foo" in project
3. Turn off filter for .* and look in project.
  
Actual results:
.foo is not listed, other .* files are (.cdtproject, .project)

Expected results:
.foo should be listed with other .* files

Additional info:
To get the changes to show up you can close and reopen the project
Comment 1 Aaron Luchko 2004-08-10 13:41:29 EDT
tracking upstream bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=71726
Comment 2 Aaron Luchko 2004-08-16 12:54:42 EDT
Was fixed upstream and will be in upstream 2.0.1
Comment 3 Aaron Luchko 2004-08-16 13:03:33 EDT
not quite yet
Comment 4 Tom Tromey 2005-09-28 11:51:48 EDT
Upstream bug fixed.

Note You need to log in before you can comment on or make changes to this bug.