Bug 1283300 - in epel, python-*client rpms require webob, but only webob1.4 is available
in epel, python-*client rpms require webob, but only webob1.4 is available
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-webob (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: RHOS Maint
Shai Revivo
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 11:21 EST by Dan Yocum
Modified: 2017-01-13 10:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-13 10:24:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2015-11-18 11:21:49 EST
Description of problem:

See $subject

Version-Release number of selected component (if applicable):

For example (but this affects all python-<service>client packages

python-cinderclient.noarch 0:1.2.1-1.el7

How reproducible:

Every

Steps to Reproduce:
1. yum install epel-release on fresh RHEL7.1
2. yum install python-cinderclient


Actual results:

Error: Package: 1:python-keystoneclient-1.3.0-1.el7.noarch (openstack-kilo)
           Requires: python-webob


Expected results:

python-cinderclient installs
Additional info:
Comment 3 Mike Burns 2017-01-13 10:24:25 EST
We don't fix EPEL bugs in OSP.  This should be filed in EPEL/Fedora and fixed there.  

We do ship client packages as part of RHEL subscriptions, so you shouldn't need EPEL anymore anyway.

Note You need to log in before you can comment on or make changes to this bug.