Bug 128332 - sshd periodically becomes unavailable without logging an error
Summary: sshd periodically becomes unavailable without logging an error
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
(Show other bugs)
Version: 2
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-21 20:05 UTC by Alan Grossfield
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-30 13:53:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Grossfield 2004-07-21 20:05:02 UTC
From Bugzilla Helper:
User-Agent: Opera/7.23 (X11; Linux i686; U)  [en]

Description of problem:
On a 2GHz Opteron with builtin Intel 82541EI Gigabit card, and a vanilla Fedora Core 2
installation (kernel-2.6.6-1.435.2.3 and openssh-3.6.1p2-34), ssh connections periodically 
die.  Every few minutes (time interval not 
reproducible) all ssh connections to the box die with following message (the box is named 
donder)

 Read from remote host donder: Connection reset by peer
Connection to donder closed

For a number of minutes after that, attempted ssh connections to the machine will give 
the error message 

blitzen 63% ssh donder
ssh: connect to host donder port 22: Connection refused

Nothing corresponding to either occurence appears in the either /var/log/secure or 
/var/log/messages on the server.  However, after several minutes, the problem magically 
fixes itself again, again with no messages in the log.

I don' t think this is a network card issue, because the box always responds to pings, and 
the machine remains usable at the console.



Version-Release number of selected component (if applicable):
openssh-3.6.1p2-34 kernel-2.6.6-1.435.2.3

How reproducible:
Always

Steps to Reproduce:
1. From another machines, ssh to the x86-64 machine
2. Wait.  The connection will die.
3.
    

Actual Results:  Connection dies

Expected Results:  Connection shouldn't die. ;)

Additional info:

Comment 1 Alan Grossfield 2004-07-21 20:22:49 UTC
I left out a possibly important piece of information: this is a dual cpu box, running the smp 
version of the kernel

Comment 2 Barry K. Nathan 2004-07-29 21:21:07 UTC
Whenever I've seen this problem, it's been because another machine was
present on the network with the same IP address. Just mentioning this
in case you haven't checked for this possibility yet.

Comment 3 Alan Grossfield 2004-07-30 13:54:05 UTC
Barry Nathan's comment is correct -- the problem was in our local 
network configuration, and NOT in fedora. 


Note You need to log in before you can comment on or make changes to this bug.