Bug 1283322 - instance stuck at migrating state when some unexpected error happened
instance stuck at migrating state when some unexpected error happened
Status: CLOSED DUPLICATE of bug 1283318
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
5.0 (RHEL 6)
Unspecified Unspecified
unspecified Severity unspecified
: z6
: 5.0 (RHEL 6)
Assigned To: Sahid Ferdjaoui
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 12:29 EST by Stephen Gordon
Modified: 2018-02-08 06:03 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 05:33:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1397153 None None None Never
OpenStack gerrit 133269 None None None Never

  None (edit)
Description Stephen Gordon 2015-11-18 12:29:01 EST
Cloned from launchpad bug 1397153.

Description:

As the code in conductor:

        try:
            live_migrate.execute(context, instance, destination,
                             block_migration, disk_over_commit)
        except (exception.NoValidHost,
                exception.ComputeServiceUnavailable,
                exception.InvalidHypervisorType,
                ....) as ex:
            with excutils.save_and_reraise_exception():
                # TODO(johngarbutt) - eventually need instance actions here
                request_spec = {'instance_properties': {
                    'uuid': instance['uuid'], },
                }
                scheduler_utils.set_vm_state_and_notify(context,
                        'compute_task', 'migrate_server',
                        dict(vm_state=instance['vm_state'],
                             task_state=None,
                             expected_task_state=task_states.MIGRATING,),
                        ex, request_spec, self.db)
        except Exception as ex:
            LOG.error(_LE('Migration of instance %(instance_id)s to host'
                          ' %(dest)s unexpectedly failed.'),
                      {'instance_id': instance['uuid'], 'dest': destination},
                      exc_info=True)
            raise exception.MigrationError(reason=six.text_type(ex))


When there is any unexpected exception raised from 'live_migrate.execute', the code will raise MigrationError, then the instance stuck at vm_state:active task_state: migrating and return 400 to user. This is confuse for user.

Specification URL (additional information):

https://bugs.launchpad.net/nova/+bug/1397153
Comment 3 Sahid Ferdjaoui 2015-12-16 05:33:56 EST
We can handle RHEL7 and RHEL6 fro OSP5 in a same BUG

*** This bug has been marked as a duplicate of bug 1283318 ***

Note You need to log in before you can comment on or make changes to this bug.