Bug 1283365 - Can't launch gnome-abrt (ImportError: cannot import name 'HTMLParseError')
Can't launch gnome-abrt (ImportError: cannot import name 'HTMLParseError')
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Francesco Frassinelli (frafra)
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F24FinalBlocker
  Show dependency treegraph
 
Reported: 2015-11-18 14:58 EST by Giulio 'juliuxpigface'
Modified: 2015-11-24 01:56 EST (History)
7 users (show)

See Also:
Fixed In Version: gnome-abrt-1.2.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 01:56:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HTMLParseError replaced with generic Exception (3.04 KB, patch)
2015-11-18 16:34 EST, Francesco Frassinelli (frafra)
no flags Details | Diff

  None (edit)
Description Giulio 'juliuxpigface' 2015-11-18 14:58:38 EST
Description of problem:
gnome-abrt doesn't work in Xfce. If launched from a terminal, it raises an exception regarding a missing library.


Version-Release number of selected component (if applicable):
gnome-abrt-1.2.0-9.fc24.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Boot a live of Xfce (Fedora Rawhide)
2. Try to launch gnome-abrt from a terminal.


Actual results:
gnome-abrt crashes on startup with the following traceback:

[liveuser@localhost ~]$ gnome-abrt
sys:1: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
Traceback (most recent call last):
  File "/usr/bin/gnome-abrt", line 47, in <module>
    import gnome_abrt.url
  File "/usr/lib64/python3.5/site-packages/gnome_abrt/url/__init__.py", line 20, in <module>
    from gnome_abrt.url import gliburltitle
  File "/usr/lib64/python3.5/site-packages/gnome_abrt/url/gliburltitle.py", line 27, in <module>
    from gnome_abrt.url.urltitle import GetURLTitleThread
  File "/usr/lib64/python3.5/site-packages/gnome_abrt/url/urltitle.py", line 24, in <module>
    from html.parser import HTMLParser, HTMLParseError
ImportError: cannot import name 'HTMLParseError'



Expected results:
gnome-abrt should not crash.

Additional info:
I'm testing on qemu-kvm with xfce.
Comment 1 satellitgo 2015-11-18 15:08:39 EST
I also have seen abrt fail to start in f24 boot.iso install of workstation
Comment 2 satellitgo 2015-11-18 15:38:41 EST
fpaste Logo

    New Paste
    Archives
    Feed
    API
    Help
    About
    Admin

Wrap Raw code
Shortened URL: http://ur1.ca/oac0p

    satellit@localhost ~]$ abrt-cli ls
    id 49a65a4f0a429c5061b0b150c99d57e187d91b49
    reason:         ibus-daemon killed by SIGABRT
    time:           Tue 17 Nov 2015 01:36:02 PM PST
    cmdline:        /usr/bin/ibus-daemon -r --xim
    package:        ibus-1.5.11-2.fc24
    uid:            1000 (satellit)
    count:          1
    Directory:      /var/spool/abrt/ccpp-2015-11-17-13:36:02-2435
    Reported:       https://retrace.fedoraproject.org/faf/reports/bthash/331706bb155ab9503a3933636082b30ebe24f0ee
     
    id cfa8af45492c95955a2228925feb5bba8d000cb2
    reason:         gnome-shell killed by SIGSEGV
    time:           Mon 16 Nov 2015 07:31:54 AM PST
    cmdline:        /usr/bin/gnome-shell
    uid:            1000
    Directory:      /var/spool/abrt/ccpp-2015-11-16-07:31:54-1889
    Reported:       cannot be reported
     
    id bea3c6930b27c363b9e26eb531c2c136aec00fee
    reason:         bijiben killed by SIGTRAP
    time:           Sun 15 Nov 2015 12:06:14 PM PST
    cmdline:        bijiben
    package:        bijiben-3.19.1-1.fc24
    uid:            1000 (satellit)
    count:          1
    Directory:      /var/spool/abrt/ccpp-2015-11-15-12:06:14-26220
    Reported:       https://retrace.fedoraproject.org/faf/reports/bthash/aa2d3f418b5be4c115ed1a512ee79a9e98cf53d4
                    https://retrace.fedoraproject.org/faf/reports/788207/
                    https://bugzilla.redhat.com/show_bug.cgi?id=1268009
    [satellit@localhost ~]$
Comment 3 Francesco Frassinelli (frafra) 2015-11-18 16:07:31 EST
HTMLParseError is not available in Python 3.5 (it has been deprecated in Python 3.4):
https://hg.python.org/cpython/file/3.4/Lib/html/parser.py#l171

Try those command:
# file=/usr/lib64/python3.5/site-packages/gnome_abrt/url/urltitle.py
# cp $file{,.bak}
# sed -i 's/, HTMLParseError//' $file
# sed -i s/HTMLParseError/Exception/ $file
Comment 4 Giulio 'juliuxpigface' 2015-11-18 16:15:26 EST
(In reply to Francesco Frassinelli (frafra) from comment #3)
> HTMLParseError is not available in Python 3.5 (it has been deprecated in
> Python 3.4):
> https://hg.python.org/cpython/file/3.4/Lib/html/parser.py#l171
> 
> Try those command:
> # file=/usr/lib64/python3.5/site-packages/gnome_abrt/url/urltitle.py
> # cp $file{,.bak}
> # sed -i 's/, HTMLParseError//' $file
> # sed -i s/HTMLParseError/Exception/ $file

I think you are right, Francesco.

I confirm that the above commands, fix the issue. I can launch gnome-abrt normally after these changes.
Comment 5 satellitgo 2015-11-18 16:22:09 EST
I can confirm that this also fixes f24 gnome wayland abrt
I can launch gnome-abrt normally after these changes.
Comment 6 Francesco Frassinelli (frafra) 2015-11-18 16:34 EST
Created attachment 1096353 [details]
HTMLParseError replaced with generic Exception

Ok, great :)
You can revert it using this command:
# mv /usr/lib64/python3.5/site-packages/gnome_abrt/url/urltitle.py{.bak,}

Here's my pull request: https://github.com/abrt/gnome-abrt/pull/146
Meanwhile, here's a Koji build which includes my patch:
https://kojipkgs.fedoraproject.org//work/tasks/5074/11895074/
Comment 7 Francesco Frassinelli (frafra) 2015-11-18 16:55:47 EST
Koji build for i686/x86:64/armv7hl: http://koji.fedoraproject.org/koji/taskinfo?taskID=11895070
Comment 8 Fedora Blocker Bugs Application 2015-11-21 04:42:01 EST
Proposed as a Blocker for 24-final by Fedora user juliuxpigface using the blocker tracking app because:

 Although I think this will be fixed shortly, as it stands now, it's a clear violation of the "2.4.6 Default application functionality" Final criteria.

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

gnome-abrt is part of the standard applications' set of Fedora Workstation and Fedora KDE Spin.

Link:
https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#Default_application_functionality
Comment 9 Petr Schindler 2015-11-23 12:43:28 EST
Discussed at 2015-11-23 blocker review meeting: [1]. 

This bug was accepted as F24 Final blocker: This bug clearly violates the final criterion "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-11-23/f24-blocker-review.2015-11-23-17.00.html

Note You need to log in before you can comment on or make changes to this bug.